summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTaichi Haradaguchi <20001722@ymail.ne.jp>2022-09-07 11:57:48 +0200
committerTaichi Haradaguchi <20001722@ymail.ne.jp>2023-07-30 09:20:29 +0200
commit5e3510dbb62229cfb01da371d39ecc27b0d44880 (patch)
treeda23c1774ebd93fae350fd1079278a5052a46889 /configure.ac
parent0e17d8ddccdee7d4f46b256153853e1cab87c99e (diff)
tdf#116412: include bz2 in internal python
Change-Id: Ie257446692227ae689fad2e61a42405a68e4f665 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/139580 Tested-by: Jenkins Reviewed-by: Taichi Haradaguchi <20001722@ymail.ne.jp>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ca0bdbcadfe7..7e60bd70cc02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2194,7 +2194,8 @@ AC_ARG_WITH(system-libs,
AC_ARG_WITH(system-bzip2,
AS_HELP_STRING([--with-system-bzip2],
- [Use bzip2 already on system. Used only when --enable-online-update=mar]),,
+ [Use bzip2 already on system. Used when --enable-online-update=mar
+ or --enable-python=internal]),,
[with_system_bzip2="$with_system_libs"])
AC_ARG_WITH(system-headers,
@@ -13551,17 +13552,16 @@ AC_SUBST(PRIVACY_POLICY_URL)
dnl ===================================================================
dnl Test whether we need bzip2
dnl ===================================================================
-SYSTEM_BZIP2=
-if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE"; then
+if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE" -o "$enable_python" = "internal"; then
AC_MSG_CHECKING([whether to use system bzip2])
if test "$with_system_bzip2" = yes; then
+ AC_MSG_RESULT([external])
SYSTEM_BZIP2=TRUE
- AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES(BZIP2, bzip2)
- FilterLibs "${BZIP2_LIBS}"
- BZIP2_LIBS="${filteredlibs}"
+ AC_CHECK_HEADER(bzlib.h, [], [AC_MSG_ERROR(bzlib.h not found. please install bzip2.)], [])
+ AC_CHECK_LIB([bz2], [BZ2_bzDecompressInit], [:], [AC_MSG_ERROR(libbz2 not found or functional.)], [])
else
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([internal])
+ SYSTEM_BZIP2=
BUILD_TYPE="$BUILD_TYPE BZIP2"
fi
fi