summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLing Yang <gnaygnil@gmail.com>2022-09-07 02:18:30 +0000
committerMichael Stahl <michael.stahl@allotropia.de>2023-01-26 16:45:19 +0000
commita03dbcf786481d7b9294354399c83b46972ac85a (patch)
treec0aa03db45345c9a72fa639a1c370cece0f3c748 /configure.ac
parent481c740ff04bc119fe1822f1a773a10a46d5d3a2 (diff)
add "LOONGARCH64" to the JAVAINTERPRETER 64bit check
Change-Id: Ia0d15eb3e235fbd750b818009b5168c61c6ff0ec Reviewed-on: https://gerrit.libreoffice.org/c/core/+/139549 Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 321cc06acbdb..5f6e4b454ce1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8587,7 +8587,7 @@ if test "$ENABLE_JAVA" != ""; then
JAVAINTERPRETER=`win_short_path_for_make "$JAVAINTERPRETER"`
elif test "$cross_compiling" != "yes"; then
case $CPUNAME in
- AARCH64|AXP|X86_64|IA64|POWERPC64|S390X|SPARC64|MIPS64|RISCV64)
+ AARCH64|AXP|X86_64|IA64|POWERPC64|S390X|SPARC64|MIPS64|RISCV64|LOONGARCH64)
if test -f "$JAVAINTERPRETER" -a "`$JAVAINTERPRETER -version 2>&1 | $GREP -i 64-bit`" = "" >/dev/null; then
AC_MSG_WARN([You are building 64-bit binaries but the JDK $JAVAINTERPRETER is 32-bit])
AC_MSG_ERROR([You should pass the --with-jdk-home option pointing to a 64-bit JDK])