summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-06-13 13:56:35 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-06-13 16:38:30 +0200
commit3c1c5c4bc9bf45c1c174f90c1d0e6226a85f46fd (patch)
tree5c2821a367a4627cb730198d8f5533b861441076 /configure.ac
parent9045f982a75d6a0e3cc92c03a218a0a0cf214891 (diff)
Exempt --enable-gui from --enable-fuzz-options
From its description, --disable-gui appears to be experimental, and it causes failures like > /usr/bin/ld: /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/workdir/CxxObject/vcl/headless/svpgdi.o: in function `dl_cairo_surface_set_device_scale(_cairo_surface*, double, double)': > /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/vcl/headless/svpgdi.cxx:2181: undefined reference to `dlsym' > /usr/bin/ld: /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/workdir/CxxObject/vcl/headless/svpgdi.o: in function `dl_cairo_surface_get_device_scale(_cairo_surface*, double*, double*)': > /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/vcl/headless/svpgdi.cxx:2189: undefined reference to `dlsym' > /usr/bin/ld: /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/workdir/CxxObject/vcl/unx/generic/glyphs/freetype_glyphcache.o: in function `(anonymous namespace)::dlFT_Done_MM_Var(FT_LibraryRec_*, FT_MM_Var_*)': > /lo/home/tdf/lode/jenkins/workspace/lo_tb_random_config_linux/vcl/unx/generic/glyphs/freetype_glyphcache.cxx:191: undefined reference to `dlsym' > collect2: error: ld returned 1 exit status (<https://ci.libreoffice.org//job/lo_tb_random_config_linux/1912/>) that are probably not worth fixing. Change-Id: Ia36a8665967601e1c6ef5af3b67d17d25822e339 Reviewed-on: https://gerrit.libreoffice.org/73960 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f8c63cc778d0..5db4063c921f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1268,13 +1268,13 @@ AC_ARG_ENABLE(gtk3_kde5,
platforms where Gtk3, Qt5 and Plasma is available.]),
,)
-libo_FUZZ_ARG_ENABLE(gui,
+AC_ARG_ENABLE(gui,
AS_HELP_STRING([--disable-gui],
[Disable use of X11 or Wayland to reduce dependencies. Not related to the --headless
command-line option. Not related to LibreOffice Online functionality. Don't use
unless you are certain you need to. Nobody will help you if you insist on trying
this and run into problems.]),
-,test "${enable_gui+set}" = set || enable_gui=yes)
+,enable_gui=yes)
libo_FUZZ_ARG_ENABLE(randr,
AS_HELP_STRING([--disable-randr],