summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-09-13 17:37:34 +0200
committerMichael Stahl <mstahl@redhat.com>2013-09-13 17:39:34 +0200
commit4956d0667d1e399007e088a0ea2079c20482e567 (patch)
tree16d5802eee1bc9224798cc751955d6052a6f5dbd /configure.ac
parent3750deae3e2d8fcf8bcf795fe327e1da370a2c4d (diff)
configure: ensure that install_name_tool matches the toolchain...
... used to build, since otherwise it'll break with "malformed object" errors. Alo replace now unused XCRUN variable. Change-Id: I58a20c34f903b7a7acb46597d94243389e6b3842
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0d4fccc452ec..4c3def0dd69c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2698,11 +2698,11 @@ if test $_os = Darwin; then
if test "$(echo $MACOSX_SDK_PATH | cut -c1-23)" = "/Applications/Xcode.app"; then
CC="`xcrun -find gcc` $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
CXX="`xcrun -find g++` $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
- XCRUN=xcrun
else
CC="gcc-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
CXX="g++-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
fi
+ INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
LIBTOOL=libtool
;;
10.7|10.8|10.9)
@@ -2719,7 +2719,7 @@ if test $_os = Darwin; then
fi
CC="`xcrun -find clang` $bitness $lto -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
CXX="`xcrun -find clang++` $bitness $lto $stdlib -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
- XCRUN=xcrun
+ INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`
LIBTOOL=`xcrun -find libtool`
RANLIB=`xcrun -find ranlib`
@@ -2820,7 +2820,7 @@ AC_SUBST(MACOSX_SDK_VERSION)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
AC_SUBST(MAC_OS_X_VERSION_MIN_REQUIRED)
AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)
-AC_SUBST(XCRUN)
+AC_SUBST(INSTALL_NAME_TOOL)
AC_SUBST(LIBTOOL) # Note that the OS X libtool command is unrelated to GNU libtool
AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
@@ -2866,7 +2866,7 @@ if test $_os = iOS; then
fi
CC="`xcrun -find clang` -arch $arch -isysroot $sysroot $lto $versionmin"
CXX="`xcrun -find clang++` -arch $arch -isysroot $sysroot $lto $versionmin"
- XCRUN=xcrun
+ INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`
LIBTOOL=`xcrun -find libtool`
RANLIB=`xcrun -find ranlib`