summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-06 18:48:21 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-12-07 07:46:20 +0100
commit665ac8f32d3aaaf7c27e8976e14fd4819edbf79b (patch)
tree282105d767a99cc945e4808ca5696918fcbea9a9 /configure.ac
parentf3e258e343dd6e3ca39fc8cb710ed6c4cbb530ba (diff)
All supported versions of Clang and GCC support at least C++17 now
Change-Id: I9130d0d1fceeb6efb1f324c99acd38eb92e67850 Reviewed-on: https://gerrit.libreoffice.org/64733 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9f60e40384a0..44143a0c81a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6205,12 +6205,12 @@ dnl ===================================================================
dnl C++11
dnl ===================================================================
-AC_MSG_CHECKING([whether $CXX supports C++17, C++14, or C++11])
+AC_MSG_CHECKING([whether $CXX supports C++17])
CXXFLAGS_CXX11=
if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
CXXFLAGS_CXX11=-std:c++17
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
- my_flags='-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z -std=gnu++14 -std=gnu++1y -std=c++14 -std=c++1y -std=gnu++11 -std=gnu++0x -std=c++11 -std=c++0x'
+ my_flags='-std=gnu++2a -std=c++2a -std=gnu++17 -std=gnu++1z -std=c++17 -std=c++1z'
for flag in $my_flags; do
if test "$COM" = MSC; then
flag="-Xclang $flag"