summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-09-24 01:49:59 +0300
committerTor Lillqvist <tml@collabora.com>2013-09-24 02:00:52 +0300
commitbbbc51e931c3a7018f2f19f61fa823190ee6fbb1 (patch)
tree52d70325b0643baba6f1ea011c139fc4aa7fcc15 /configure.ac
parent2f4d7eacabd62db35777682bcca353e142e024bf (diff)
Create a proper Info.plist for the OS X app bundle already in configure
After recent instdir changes the SCPZIP_REPLACE thing was not used any more for Info.plist, so all the ${FOO} things were left in Info.plist unexpanded with predictably wonky results, a non-working app. Instead just expand it from the configure script. While at it, use a correct CFBundleShortVersionString: only three integers should be in that. Also, hardcode FILEFORMATNAME as OpenOffice.org and FILEFORMATVERSION as 1.0, and drop the "variables", as that is what those "variables" *means*. They were used to refer to the OOo 1.0 formats. (It would have been utterly wrong to define them as something else, like another product name and a newer version number, in openoffice.lst, so pointless to have them there.) Drop the meaningless BUILDIDCWS. Change-Id: I4030aa060b78e8b3fb812a6362869996e8db7d3d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1f3ea9b2f7b2..0bcbfaeea7a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,11 @@ LIBO_VERSION_MINOR=$2
LIBO_VERSION_MICRO=$3
LIBO_VERSION_PATCH=$4
+# The CFBundleShortVersionString in Info.plist consists of three integers, so encode the third
+# as the micro version times 1000 plus the patch number. Unfortunately the LIBO_VERSION_SUFFIX can be anything so
+# no way to encode that into an integer in general.
+MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.`expr $LIBO_VERSION_MICRO '*' 1000 + $LIBO_VERSION_PATCH`
+
LIBO_VERSION_SUFFIX=$5
# Split out LIBO_VERSION_SUFFIX_SUFFIX... horrible crack. But apparently wanted separately in
# openoffice.lst as ABOUTBOXPRODUCTVERSIONSUFFIX. Note that the double brackets are for m4's sake,
@@ -123,6 +128,7 @@ AC_SUBST(LIBO_VERSION_MAJOR)
AC_SUBST(LIBO_VERSION_MINOR)
AC_SUBST(LIBO_VERSION_MICRO)
AC_SUBST(LIBO_VERSION_PATCH)
+AC_SUBST(MACOSX_BUNDLE_SHORTVERSION)
AC_SUBST(LIBO_VERSION_SUFFIX)
AC_SUBST(LIBO_VERSION_SUFFIX_SUFFIX)
@@ -12595,7 +12601,11 @@ if test -f config_host.mk; then
config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
-AC_CONFIG_FILES([config_host.mk Makefile lo.xcent instsetoo_native/util/openoffice.lst])
+AC_CONFIG_FILES([config_host.mk
+ Makefile
+ lo.xcent
+ instsetoo_native/util/openoffice.lst
+ sysui/desktop/macosx/Info.plist])
AC_CONFIG_HEADERS([config_host/config_buildid.h])
AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_features.h])