summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-03-18 11:25:41 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2018-03-18 17:21:03 +0100
commitd7ecf4a4e37a9eeffa2b40f9fe5a2e6a8f90c876 (patch)
tree26cea37ed3ca6d89cfcd18b0b46d527f1b6731d3 /configure.ac
parentf68929ac611fdda19c1ee413effc59d33aa5ef97 (diff)
properly check for gpgconf (and --create-socketdir) working
Change-Id: I21268e5950381845eb90bf66a42a99adc3821eaa Reviewed-on: https://gerrit.libreoffice.org/51493 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fa43fd0c31e..ff011fbdd57e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10355,6 +10355,27 @@ elif test "$_os" = "Linux" -o "$_os" = "Darwin" -o "$_os" = "WINNT" ; then
# gpg installation to run OpenPGP signature verification
AC_DEFINE([HAVE_FEATURE_GPGVERIFY])
fi
+ if test "$_os" = "Linux"; then
+ uid=`id -u`
+ AC_MSG_CHECKING([for /run/user/$uid])
+ if test -d /run/user/$uid; then
+ AC_MSG_RESULT([yes])
+ AC_PATH_PROG(GPGCONF, gpgconf)
+ AC_MSG_CHECKING([for gpgconf --create-socketdir... ])
+ if $(GPGCONF) --dump-options > /dev/null ; then
+ if $(GPGCONF) --dump-options | grep -q create-socketdir ; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_GPGCONF_SOCKETDIR])
+ else
+ AC_MSG_RESULT([no])
+ fi
+ else
+ AC_MSG_RESULT([no. missing or broken gpgconf?])
+ fi
+ else
+ AC_MSG_RESULT([no])
+ fi
+ fi
fi
AC_SUBST(ENABLE_GPGMEPP)
AC_SUBST(SYSTEM_GPGMEPP)
@@ -10364,6 +10385,8 @@ AC_SUBST(LIBASSUAN_CFLAGS)
AC_SUBST(LIBASSUAN_LIBS)
AC_SUBST(GPGMEPP_CFLAGS)
AC_SUBST(GPGMEPP_LIBS)
+AC_SUBST(GPGCONF)
+AC_SUBST(HAVE_GPGCONF_SOCKETDIR)
AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
if test "x$enable_ext_wiki_publisher" = "xyes" -a "x$enable_extension_integration" != "xno" -a "$with_java" != "no"; then