summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-07-14 11:01:48 +0300
committerTor Lillqvist <tml@collabora.com>2015-07-14 11:03:56 +0300
commitf3df77accae2941ba9c6a5e48b84d661f7a87863 (patch)
tree333a90683d1cf8ed2cb0bd0f9e80fee4c69c973b /configure.ac
parenta04354ecb34216d7fb9868f701fd3ee2b70883c8 (diff)
With --enable-gtk3 we need GLib >= 2.38
The G_ADD_PRIVATE used in libreofficekit/source/gtk/lokdocview.cxx is from 2.38. Change-Id: I2058932f8252d2715f970f020160f4f960987125
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c362aa6deb2..87d7990de86c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9972,11 +9972,11 @@ if test "x$enable_gtk3" = "xyes"; then
AC_MSG_ERROR([System cairo required for gtk3 support, do not combine --enable-gtk3 with --without-system-cairo])
fi
: ${with_system_cairo:=yes}
- PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 gmodule-no-export-2.0 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.2 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
else
- AC_MSG_ERROR([gtk3 libraries of the correct versions, not found])
+ AC_MSG_ERROR([gtk3 or dependent libraries of the correct versions, not found])
fi
GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
fi