summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2013-09-17 13:56:12 +0200
committerMatúš Kukan <matus.kukan@gmail.com>2013-09-17 19:37:42 +0200
commitf5b840a3ee14a2086647596246d3491a58bf33bb (patch)
tree84b5b61340679be7d7929583090b3463651cdeee /configure.ac
parentbb15aeb0bbd063e557f21c4edde03949c66173fd (diff)
goodbye linkoo.. you have served well
This commit: - removes linkoo and --disable-linkoo option - removes 'dev-update' make target - creates --disable-ooenv option - removes LD_LIBRARY_PATH and PATH settings in ooenv Change-Id: I9530558531e9cb58b8282754ec8a6c655f190480
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 14 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c145970e4e82..bf78f359fe49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -848,9 +848,9 @@ AC_ARG_ENABLE(compiler-plugins,
[Enable compiler plugins that will perform additional checks during
building. Enabled automatically by --enable-dbgutil.]))
-AC_ARG_ENABLE(linkoo,
- AS_HELP_STRING([--disable-linkoo],
- [Disable linkoo for the smoketest installation.]))
+AC_ARG_ENABLE(ooenv,
+ AS_HELP_STRING([--disable-ooenv],
+ [Disable ooenv for the instdir installation.]))
AC_ARG_ENABLE(lto,
AS_HELP_STRING([--enable-lto],
@@ -4601,21 +4601,18 @@ else
fi
AC_SUBST(ASSERT_ALWAYS_ABORT)
-dnl Determine whether to use linkoo for the smoketest installation
-dnl ===================================================================
-AC_MSG_CHECKING([whether to use linkoo for the smoketest installation])
-if test $_os = Darwin; then
- enable_linkoo=no
-fi
-
-if test "$enable_linkoo" = "no"; then
- DISABLE_LINKOO="TRUE"
- AC_MSG_RESULT([no])
-else
- DISABLE_LINKOO=
- AC_MSG_RESULT([yes])
+# Determine whether to use ooenv for the instdir installation
+# ===================================================================
+if test $_os != "WINNT" -a $_os != "Darwin"; then
+ AC_MSG_CHECKING([whether to use ooenv for the instdir installation])
+ if test "$enable_ooenv" = "no"; then
+ AC_MSG_RESULT([no])
+ else
+ ENABLE_OOENV="TRUE"
+ AC_MSG_RESULT([yes])
+ fi
fi
-AC_SUBST(DISABLE_LINKOO)
+AC_SUBST(ENABLE_OOENV)
if test "$enable_headless" = "yes"; then
# be sure to do not mess with uneeded stuff