summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2016-12-08 11:07:42 +0200
committerTor Lillqvist <tml@collabora.com>2016-12-08 14:21:20 +0200
commit59d85e1b26e18c3aaa94d586806b7fd88dfaec6a (patch)
tree04f75b8666ec55bd71ef68b9cfeaf6bbb846330c /configure.ac
parentd75f839329c7ac53b0361a81cb5e2d7143abb907 (diff)
If we fuzzed --enable-compiler-plugins as yes but aren't using Clang, reset it
Change-Id: I4a910649ec6b4ec5f999e009802038457cf94363
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b32c24ae651f..589aff437212 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6666,6 +6666,14 @@ dnl ===================================================================
COMPILER_PLUGINS=
# currently only Clang
+
+if test "$COM_IS_CLANG" != "TRUE"; then
+ if test "$libo_fuzzed_enable_compiler_plugins" = yes -a "$enable_compiler_plugins" = yes; then
+ AC_MSG_NOTICE([Resetting --enable-compiler-plugins=no])
+ enable_compiler_plugins=no
+ fi
+fi
+
if test "$COM_IS_CLANG" = "TRUE"; then
if test -n "$enable_compiler_plugins"; then
compiler_plugins="$enable_compiler_plugins"