summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-05-10 00:34:54 +0200
committerRene Engelhard <rene@debian.org>2018-05-10 12:12:45 +0200
commitc1abccec44841bfad287b7227ebfc38daa010369 (patch)
tree33c5036a57880da4317a5ccbec43b35208945bd6 /configure.ac
parent0e384e1080381e894b590fd0a6d453568715e8fa (diff)
configure: fix gdrive,alfresco and onedrive id/secret diagnostics
e.g. GDRIVE_CLIENT_ID was checked with -z but it actually is "", so this always was outputted as "set". Change-Id: I9ee3e742655af721ba2b9d56e52d86b17331c65c Reviewed-on: https://gerrit.libreoffice.org/54057 Tested-by: Rene Engelhard <rene@debian.org> Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Rene Engelhard <rene@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 9 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index fca2d4d9044b..b62b9e122a4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12217,59 +12217,40 @@ AC_SUBST(TESTINSTALLDIR)
# ===================================================================
AC_MSG_CHECKING([for Google Drive client id and secret])
-GDRIVE_CLIENT_ID="\"$with_gdrive_client_id\""
-GDRIVE_CLIENT_SECRET="\"$with_gdrive_client_secret\""
if test "$with_gdrive_client_id" = "no" -o -z "$with_gdrive_client_id"; then
+ AC_MSG_RESULT([not set])
GDRIVE_CLIENT_ID="\"\""
-fi
-
-if test "$with_gdrive_client_secret" = "no" -o -z "$with_gdrive_client_secret"; then
GDRIVE_CLIENT_SECRET="\"\""
-fi
-
-if test -z "$GDRIVE_CLIENT_ID" -o -z "$GDRIVE_CLIENT_SECRET"; then
- AC_MSG_RESULT([not set])
else
AC_MSG_RESULT([set])
+ GDRIVE_CLIENT_ID="\"$with_gdrive_client_id\""
+ GDRIVE_CLIENT_SECRET="\"$with_gdrive_client_secret\""
fi
-
AC_DEFINE_UNQUOTED(GDRIVE_CLIENT_ID, $GDRIVE_CLIENT_ID)
AC_DEFINE_UNQUOTED(GDRIVE_CLIENT_SECRET, $GDRIVE_CLIENT_SECRET)
AC_MSG_CHECKING([for Alfresco Cloud client id and secret])
-ALFRESCO_CLOUD_CLIENT_ID="\"$with_alfresco_cloud_client_id\""
-ALFRESCO_CLOUD_CLIENT_SECRET="\"$with_alfresco_cloud_client_secret\""
if test "$with_alfresco_cloud_client_id" = "no" -o -z "$with_alfresco_cloud_client_id"; then
+ AC_MSG_RESULT([not set])
ALFRESCO_CLOUD_CLIENT_ID="\"\""
-fi
-
-if test "$with_alfresco_cloud_client_secret" = "no" -o -z "$with_alfresco_cloud_client_secret"; then
ALFRESCO_CLOUD_CLIENT_SECRET="\"\""
-fi
-
-if test -z "$ALFRESCO_CLOUD_CLIENT_ID" -o -z "$ALFRESCO_CLOUD_CLIENT_SECRET"; then
- AC_MSG_RESULT([not set])
else
AC_MSG_RESULT([set])
+ ALFRESCO_CLOUD_CLIENT_ID="\"$with_alfresco_cloud_client_id\""
+ ALFRESCO_CLOUD_CLIENT_SECRET="\"$with_alfresco_cloud_client_secret\""
fi
AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_ID, $ALFRESCO_CLOUD_CLIENT_ID)
AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_SECRET, $ALFRESCO_CLOUD_CLIENT_SECRET)
AC_MSG_CHECKING([for OneDrive client id and secret])
-ONEDRIVE_CLIENT_ID="\"$with_onedrive_client_id\""
-ONEDRIVE_CLIENT_SECRET="\"$with_onedrive_client_secret\""
if test "$with_onedrive_client_id" = "no" -o -z "$with_onedrive_client_id"; then
+ AC_MSG_RESULT([not set])
ONEDRIVE_CLIENT_ID="\"\""
-fi
-
-if test "$with_onedrive_client_secret" = "no" -o -z "$with_onedrive_client_secret"; then
ONEDRIVE_CLIENT_SECRET="\"\""
-fi
-
-if test -z "$ONEDRIVE_CLIENT_ID" -o -z "$ONEDRIVE_CLIENT_SECRET"; then
- AC_MSG_RESULT([not set])
else
AC_MSG_RESULT([set])
+ ONEDRIVE_CLIENT_ID="\"$with_onedrive_client_id\""
+ ONEDRIVE_CLIENT_SECRET="\"$with_onedrive_client_secret\""
fi
AC_DEFINE_UNQUOTED(ONEDRIVE_CLIENT_ID, $ONEDRIVE_CLIENT_ID)
AC_DEFINE_UNQUOTED(ONEDRIVE_CLIENT_SECRET, $ONEDRIVE_CLIENT_SECRET)