summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei@libreoffice.org>2023-05-31 21:33:56 -0400
committerKohei Yoshida <kohei@libreoffice.org>2023-10-25 03:59:57 +0200
commitb14583ba37a6d7ce398ccd3cf339f954785b03d8 (patch)
treecf48ebcb363c1f782b3f238f5a49dea367345b84 /configure.ac
parentb5d194d1d37131f921853b78d659c63178de2bc6 (diff)
Support conditional loading of Apache Parquet files into Calc
Also, use orcus::create_filter() and simplify the logic a bit. This requires orcus 0.19.1 or newer. Note that this change makes it possible to load Apache Parquet files if and only if orcus has been built with the parquet import filter enabled. Using orcus without the parquet import filter enabled will not break the build or run-time behavior; you just can't load parquet files. Change-Id: I9f8820998b7b0667d1e7cd532c32b1c7e55ca999 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/158411 Tested-by: Jenkins Reviewed-by: Kohei Yoshida <kohei@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 999ab64289e8..c8466ae65e01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10878,7 +10878,7 @@ fi
dnl ===================================================================
dnl Orcus
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.18 >= 0.18.0])
+libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.18 >= 0.19.1])
if test "$with_system_orcus" != "yes"; then
if test "$SYSTEM_BOOST" = "TRUE"; then
dnl Link with Boost.System