summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2021-11-25 08:45:41 +0000
committerMichael Stahl <michael.stahl@allotropia.de>2022-03-09 19:00:30 +0100
commit5baaae8f89b7d61bc5a9349cb6fd42a5a3423af3 (patch)
tree5f9c3901f9321527f6780f67313b7126ec490cf5 /configure.ac
parentaa2887120c95316fa9d9a0c9a1bf453360868e6d (diff)
required curl_multi_wakeup is only in >= curl 7.68.0
Change-Id: I53878de49549098ff90ef1f68f88880a6eb5bf55 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/125797 Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com> (cherry picked from commit 70dd00f23ee53ea5ae7f3c292906335fb6000ab4)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 1 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 0aab88e1d64a..271f4e4240de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9279,32 +9279,7 @@ if test "$with_system_curl" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_CURL=TRUE
- # First try PKGCONFIG and then fall back
- PKG_CHECK_MODULES(CURL, libcurl >= 7.19.4,, [:])
-
- if test -n "$CURL_PKG_ERRORS"; then
- AC_PATH_PROG(CURLCONFIG, curl-config)
- if test -z "$CURLCONFIG"; then
- AC_MSG_ERROR([curl development files not found])
- fi
- CURL_LIBS=`$CURLCONFIG --libs`
- FilterLibs "${CURL_LIBS}"
- CURL_LIBS="${filteredlibs}"
- CURL_CFLAGS=$("$CURLCONFIG" --cflags | sed -e "s/-I/${ISYSTEM?}/g")
- curl_version=`$CURLCONFIG --version | $SED -e 's/^libcurl //'`
-
- AC_MSG_CHECKING([whether libcurl is >= 7.19.4])
- case $curl_version in
- dnl brackets doubled below because Autoconf uses them as m4 quote characters,
- dnl so they need to be doubled to end up in the configure script
- 7.19.4|7.19.[[5-9]]|7.[[2-9]]?.*|7.???.*|[[8-9]].*|[[1-9]][[0-9]].*)
- AC_MSG_RESULT([yes])
- ;;
- *)
- AC_MSG_ERROR([no, you have $curl_version])
- ;;
- esac
- fi
+ PKG_CHECK_MODULES(CURL, libcurl >= 7.68.0)
ENABLE_CURL=TRUE
elif test $_os = iOS; then