summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-01-11 19:51:59 +0200
committerTor Lillqvist <tml@collabora.com>2017-01-11 19:57:29 +0200
commit9334de4f6ddc3e7d60f727aa845c7aa7db3fe019 (patch)
tree4a6a1ae91ca64841e93741ced870e3c3b030af8b /configure.ac
parent38ce989b4f9d2aead097e5a2e95b819def7e2624 (diff)
Don't suggest any "devel packages" on macOS
Installing random 3rd-party "devel packages" is exactly what we don't want people to do when building on macOS. And anyway, there is no reason to believe this particular check will ever fail (there even is a comment that says "MacOS X has system MIT Kerberos 5 since 10.4"), unless something is very wrong. Change-Id: Ic880e59358c7c510de9db29e66dfeee7f4e85b4d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dce68923da52..24cb7a807a24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8540,12 +8540,14 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
if test "$with_krb5" != "no"; then
WITH_KRB5=TRUE
save_LIBS=$LIBS
+ # Not sure whether it makes any sense here to search multiple potential libraries; it is not likely
+ # that the libraries where these functions are located on macOS will change, is it?
AC_SEARCH_LIBS(com_err, [com_err 'com_err -lssl -lcrypto' krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
- [AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5, try installing libcom_err devel package])])
+ [AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5])])
KRB5_LIBS=$LIBS
LIBS=$save_LIBS
AC_SEARCH_LIBS(krb5_sendauth, [krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
- [AC_MSG_ERROR([could not find function 'krb5_sendauth' required for Kerberos 5, try installing krb5 devel package])])
+ [AC_MSG_ERROR([could not find function 'krb5_sendauth' required for Kerberos 5])])
KRB5_LIBS="$KRB5_LIBS $LIBS"
LIBS=$save_LIBS
fi