summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-12-17 08:07:50 +0100
committerStephan Bergmann <sbergman@redhat.com>2019-12-17 09:19:13 +0100
commit038a4a81e5c5c37fcfaccd1358eafbf1915b0894 (patch)
tree9caba20d87b02c2d14882778e8dec6e7e8a3df60 /configure.ac
parent7b26e517d50ca4c34fa7a6291948fb200b2e5d71 (diff)
Remove dated check for jre sub-dir in JDK
Since Java 9, a JDK installation no longer necessarily has a jre sub-dir, see <https://docs.oracle.com/javase/9/install/ installed-directory-structure-jdk-and-jre.htm> vs. <https://docs.oracle.com/javase/8/docs/technotes/tools/windows/jdkfiles.html>. The check for a jre sub-dir had been there ever since 157d22babb277a9e7bc750a74737cd60e84dfee8 "INTEGRATION: CWS rodarvus01", but the code that determines a working JAVA_HOME has been improved a lot since then. Given that the current check can be misleading (see <https://lists.freedesktop.org/archives/libreoffice/2019-December/084005.html> "Re: what jdk for build?"), better remove it completely and hope that the code determining a working JAVA_HOME is good enough by now. Change-Id: Ib1da3c00b8a3f1e54d5204e6ecd43b4c4441c827 Reviewed-on: https://gerrit.libreoffice.org/85257 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 60c78636f363..f15253defe27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7714,18 +7714,13 @@ _ACEOF
;;
esac
if test ! -f "$JAVA_HOME/lib/jvm.cfg" -a "x$with_jdk_home" = "x"; then
- JAVA_HOME_OK="NO"
- fi
- elif test ! -d "$JAVA_HOME/jre" -a "x$with_jdk_home" = "x"; then
- JAVA_HOME_OK="NO"
- fi
- if test "$JAVA_HOME_OK" = "NO"; then
- AC_MSG_WARN([JAVA_HOME was not explicitly informed with --with-jdk-home. the configure script])
- AC_MSG_WARN([attempted to find JAVA_HOME automatically, but apparently it failed])
- AC_MSG_WARN([in case JAVA_HOME is incorrectly set, some projects will not be built correctly])
- add_warning "JAVA_HOME was not explicitly informed with --with-jdk-home. the configure script"
- add_warning "attempted to find JAVA_HOME automatically, but apparently it failed"
- add_warning "in case JAVA_HOME is incorrectly set, some projects will not be built correctly"
+ AC_MSG_WARN([JAVA_HOME was not explicitly informed with --with-jdk-home. the configure script])
+ AC_MSG_WARN([attempted to find JAVA_HOME automatically, but apparently it failed])
+ AC_MSG_WARN([in case JAVA_HOME is incorrectly set, some projects will not be built correctly])
+ add_warning "JAVA_HOME was not explicitly informed with --with-jdk-home. the configure script"
+ add_warning "attempted to find JAVA_HOME automatically, but apparently it failed"
+ add_warning "in case JAVA_HOME is incorrectly set, some projects will not be built correctly"
+ fi
fi
PathFormat "$JAVA_HOME"
JAVA_HOME="$formatted_path"