summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-01-28 14:05:12 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-01-28 18:35:49 +0100
commit6171812c5520b80dabd007c709143fbf43b527fb (patch)
treefdaa56a1af42c77b8ad6c7f6dfdc8134416c1fd6 /configure.ac
parent45dd6e5c23d7f826bd9b9db4bd8b12c864efa9e0 (diff)
HAVE_GCC_ATTRIBUTE_WARN_UNUSED should always be true now for Clang/GCC
...but for safety, leave the configure.ac check in for some longer. Change-Id: I90cba5812492ba85d7723ff71aba75b7721b9622 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/87621 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4b25ed9bf662..d16b49a69c83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6445,17 +6445,17 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
- dnl Available in GCC 4.9 and at least since Clang 3.4:
- AC_MSG_CHECKING([whether $CXX_BASE supports __attribute__((warn_unused))])
+ dnl Available in GCC 4.9 and at least since Clang 3.4; this check can eventually be removed
+ dnl completely (e.g., aftger libreoffice-6-5 branch off):
+ AC_MSG_CHECKING([that $CXX_BASE supports __attribute__((warn_unused))])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS -Werror"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
struct __attribute__((warn_unused)) dummy {};
])], [
- AC_DEFINE([HAVE_GCC_ATTRIBUTE_WARN_UNUSED],[1])
AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
+ ], [AC_MSG_ERROR([no])])
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])
fi