summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 16:57:35 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:09 +0100
commit0443d0a90ecb9ac54484c1c2c6b9d74892eb35ae (patch)
tree14d96f096ee449348730e9bade2571cb23f46482 /configure.ac
parent379f978387a8b017a41c2682c0b39444f17a2230 (diff)
normalize values of SYSTEM_PYTHON, SYSTEM_MYSQL_CPPCONN
Change-Id: I8932febdd39c35f23fb3a89703b69e25302f5678
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fc59e5a0ed76..c95a723aa1af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8170,7 +8170,7 @@ fi
dnl By now enable_python should be "system", "internal" or "no"
case $enable_python in
system)
- SYSTEM_PYTHON=YES
+ SYSTEM_PYTHON=TRUE
if test "$CROSS_COMPILING" != YES; then
dnl Check if the headers really work
@@ -8201,7 +8201,7 @@ int main(int argc, char **argv) {
;;
internal)
- SYSTEM_PYTHON=NO
+ SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=3
PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.3
@@ -8220,7 +8220,7 @@ internal)
;;
no)
DISABLE_PYTHON=TRUE
- SYSTEM_PYTHON=NO
+ SYSTEM_PYTHON=
;;
*)
AC_MSG_ERROR([Internal configure script error, invalid enable_python value "$enable_python"])
@@ -8336,7 +8336,7 @@ if test "$ENABLE_MARIADBC" = "TRUE"; then
AC_MSG_CHECKING([MySQL Connector/C++])
if test "$with_system_mysql_cppconn" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_MYSQL_CPPCONN=YES
+ SYSTEM_MYSQL_CPPCONN=TRUE
AC_LANG_PUSH([C++])
AC_CHECK_HEADER(mysql_driver.h, [],
[AC_MSG_ERROR(mysql_driver.h not found. install MySQL C++ Connectivity)], [])
@@ -8365,7 +8365,7 @@ int main(int argc, char **argv) {
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE MYSQLCPPCONN"
- SYSTEM_MYSQL_CPPCONN=NO
+ SYSTEM_MYSQL_CPPCONN=
fi
AC_LANG_POP([C++])
fi