summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 19:17:42 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:10 +0100
commit187194b8aea14350e38bf181dc97c2f1019222f0 (patch)
tree3c896e9be9c3caabcf33c24a2033e1d96ef38f28 /configure.ac
parent5378deaea3a499003be14f97bd1a9fb3e729a698 (diff)
normalize values of SYSTEM_NPAPI_HEADERS, SYSTEM_ICU
Change-Id: I7f1153e4a07a4116417a7734d867f2d0feda1ee4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f660a9b1d083..f090ddb7f593 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8961,7 +8961,7 @@ AC_MSG_CHECKING([which NPAPI headers to use])
if test "$with_system_npapi_headers" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_NPAPI_HEADERS=YES
+ SYSTEM_NPAPI_HEADERS=TRUE
# First try npapi-sdk:
PKG_CHECK_MODULES(NPAPI_HEADERS, npapi-sdk, [LOCATED=yes], [LOCATED=no])
# Then go with libxul:
@@ -8998,7 +8998,7 @@ else
AC_MSG_RESULT([internal])
dnl ...but will not be built/used unless ENABLE_NPAPI_FROM_BROWSER or
dnl ENABLE_NPAPI_INTO_BROWSER is TRUE
- SYSTEM_NPAPI_HEADERS=NO
+ SYSTEM_NPAPI_HEADERS=
fi
AC_SUBST(NPAPI_HEADERS_CFLAGS)
AC_SUBST(SYSTEM_NPAPI_HEADERS)
@@ -9033,7 +9033,7 @@ ICU_RECLASSIFIED_HEBREW_LETTER="YES"
AC_MSG_CHECKING([which icu to use])
if test "$with_system_icu" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_ICU=YES
+ SYSTEM_ICU=TRUE
AC_LANG_PUSH([C++])
AC_MSG_CHECKING([for unicode/rbbi.h])
AC_PREPROC_IFELSE([AC_LANG_SOURCE([[unicode/rbbi.h]])],[AC_MSG_RESULT(checked.)],[AC_MSG_ERROR(icu headers not found.)])
@@ -9118,7 +9118,7 @@ You can use --with-system-icu-for-build=force to use it anyway.])
libo_MINGW_CHECK_DLL([icuuc][$ICU_MAJOR][$ICU_MINOR])
else
AC_MSG_RESULT([internal])
- SYSTEM_ICU="NO"
+ SYSTEM_ICU=
BUILD_TYPE="$BUILD_TYPE ICU"
# surprisingly set these only for "internal" (to be used by various other
# external libs): the system icu-config is quite unhelpful and spits out