summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-06-02 23:44:23 +0300
committerTor Lillqvist <tml@collabora.com>2014-06-02 23:44:23 +0300
commit67f987f6ffcc057d3dae0a39fe7cdb680a455408 (patch)
tree69ffb618c33b520a84ac64c0efbbc72776c1180d /configure.ac
parent05eccdfc3464839ebc1d283b648588be671d65b9 (diff)
Accept the OS X 10.10 SDK
Change-Id: Ic9c210e51f9f6b776e77988fdb1c719ee3d9d73a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8e1a5db95435..834694548a12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2742,8 +2742,11 @@ if test $_os = Darwin; then
10.9)
MACOSX_SDK_VERSION=1090
;;
+ 10.10)
+ MACOSX_SDK_VERSION=101000
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.5--10])
;;
esac
@@ -2795,7 +2798,7 @@ if test $_os = Darwin; then
fi
fi
;;
- 10.8|10.9)
+ 10.8|10.9|10.10)
xcodepath="`xcode-select -print-path`"
if test -d "$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"; then
MACOSX_SDK_PATH="$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"
@@ -2844,8 +2847,11 @@ if test $_os = Darwin; then
10.9)
MAC_OS_X_VERSION_MIN_REQUIRED="1090"
;;
+ 10.10)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.5--10])
;;
esac
@@ -2887,7 +2893,7 @@ if test $_os = Darwin; then
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
LIBTOOL=libtool
;;
- 10.7|10.8|10.9)
+ 10.7|10.8|10.9|10.10)
if test "$with_macosx_version_min_required" != 10.6; then
# Use libc++ instead of libstdc++ when possible
stdlib=-stdlib=libc++
@@ -2924,8 +2930,11 @@ if test $_os = Darwin; then
10.9)
MAC_OS_X_VERSION_MAX_ALLOWED="1090"
;;
+ 10.10)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.5--10])
;;
esac