summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Mencken <dougmencken@gmail.com>2014-05-14 07:33:48 -0400
committerTor Lillqvist <tml@collabora.com>2014-05-14 12:26:29 +0000
commite5934962bd55970c54b399351559e90d02b75b6b (patch)
treea796be45d1f126de37f9a0fff2df84dac1540781 /configure.ac
parentc8695c6cce4aaa07ab2d615783d74037abb241b5 (diff)
use bundled (non-system) versions of libxml2 and libxslt for OS X <10.6
fixes fdo#78612 and fdo#77893 Change-Id: Iac36211095cc009a356f335a93a184ea5078214d Reviewed-on: https://gerrit.libreoffice.org/9353 Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 28d4291c26f5..ef6bf92e28d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7820,7 +7820,11 @@ if test "$with_system_libxml" = "auto"; then
with_system_libxml="$with_system_libs"
;;
*)
- with_system_libxml=yes
+ if test "$_os" = "Darwin" -a $MAC_OS_X_VERSION_MAX_ALLOWED -lt 1060; then
+ with_system_libxml=no
+ else
+ with_system_libxml=yes
+ fi
;;
esac
fi