summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2020-03-27 10:54:39 +0100
committerLuboš Luňák <l.lunak@collabora.com>2020-03-27 12:07:27 +0100
commit5bcd3335012c25edb03c858b3fb44ec26b0a25d4 (patch)
tree97cbc1b23ccb4045871ed3764e911a8778df7b8a /configure.ac
parent1a7489039e8acbd9499276fdb6e747e11d3ecffe (diff)
revert the gyp-based nss build changes
https://lists.freedesktop.org/archives/libreoffice/2020-March/084769.html etc. This reverts commit c76fdcf1cfa1242e66b50ebe80d6eac1baae37a9. This reverts commit 10f52ab4d27263439d59f55f40e88ad2fde0cf71. This reverts commit eac806e8dcd9ee6439ac8695978ff6b62cc6b8d2. This reverts commit d591a682e46ff352f06a61c024ef661dd17f4ea4. This reverts commit 12235d3390a7fc5146bf65f9d6166034b8a048ee. This reverts commit 23245f723fb29262b8543d6447d1b0bb69cb50fb. This reverts commit 91658b402b66b67c785687d5b3a76e3183fe76bf. This reverts commit 5feadfad0cc3be2680213d2e5f6f786b2f4cc74f. This reverts commit fecca49c309fc723c524f12fa671114b316a5562. This reverts commit c6a9454e744289cf2004b42b3c90854b2db8382b. This reverts commit a1a62a70411cb6041b5930ead08280d5e1e7b5f9. This reverts commit 8512f4ca090c85477a6670438aeefe7fdfcf8a98. This reverts commit 532ffb7a297d55b495141ce33692df5d9917b54f. Change-Id: Iaa48d692bea2ca2468cdd5f8ad26ad91c0c31dde Reviewed-on: https://gerrit.libreoffice.org/c/core/+/91199 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 0 insertions, 54 deletions
diff --git a/configure.ac b/configure.ac
index f2f27e9522f1..5447d184fc3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -586,7 +586,6 @@ test_fontconfig=yes
test_cairo=no
test_gdb_index=no
test_split_debug=no
-nss_needs_ninja=no
# Default values, as such probably valid just for Linux, set
# differently below just for Mac OSX, but at least better than
@@ -610,7 +609,6 @@ solaris*)
build_gstreamer_1_0=yes
test_freetype=yes
build_skia=yes
- nss_needs_ninja=yes
_os=SunOS
dnl ===========================================================
@@ -640,7 +638,6 @@ linux-gnu*|k*bsd*-gnu*)
build_skia=yes
test_gdb_index=yes
test_split_debug=yes
- nss_needs_ninja=yes
if test "$enable_fuzzers" != yes; then
test_freetype=yes
test_fontconfig=yes
@@ -678,7 +675,6 @@ cygwin*|interix*)
test_freetype=no
test_fontconfig=no
build_skia=yes
- nss_needs_ninja=yes
_os=WINNT
DLLPOST=".dll"
@@ -734,7 +730,6 @@ freebsd*)
test_gtk3_kde5=yes
test_freetype=yes
build_skia=yes
- nss_needs_ninja=yes
AC_MSG_CHECKING([the FreeBSD operating system release])
if test -n "$with_os_version"; then
OSVERSION="$with_os_version"
@@ -763,7 +758,6 @@ freebsd*)
test_gtk3_kde5=yes
test_freetype=yes
build_skia=yes
- nss_needs_ninja=yes
PTHREAD_LIBS="-pthread -lpthread"
_os=NetBSD
;;
@@ -777,7 +771,6 @@ aix*)
openbsd*)
test_freetype=yes
- nss_needs_ninja=yes
PTHREAD_CFLAGS="-D_THREAD_SAFE"
PTHREAD_LIBS="-pthread"
_os=OpenBSD
@@ -789,7 +782,6 @@ dragonfly*)
test_gtk3_kde5=yes
test_freetype=yes
build_skia=yes
- nss_needs_ninja=yes
PTHREAD_LIBS="-pthread"
_os=DragonFly
;;
@@ -9674,58 +9666,12 @@ if test $_os != iOS -a "$enable_fuzzers" != "yes"; then
AC_DEFINE(HAVE_FEATURE_NSS)
ENABLE_NSS="TRUE"
AC_DEFINE(ENABLE_NSS)
- # internal nss uses gyp
- if test -z "$SYSTEM_NSS"; then
- BUILD_TYPE="$BUILD_TYPE GYP"
- fi
elif test $_os != iOS ; then
with_tls=openssl
fi
AC_SUBST(ENABLE_NSS)
dnl ===================================================================
-dnl Search for ninja
-dnl ===================================================================
-AC_MSG_CHECKING([for ninja])
-
-# try to use our own ninja if it is available and NINJA was not already defined
-if test -z "$NINJA"; then
- if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/ninja" ; then
- NINJA="$LODE_HOME/opt/bin/ninja"
- elif test -x "/opt/lo/bin/ninja"; then
- NINJA="/opt/lo/bin/ninja"
- fi
-fi
-
-for a in "$NINJA" ninja ninja-build; do
- if test -n "$a"; then
- $a --version > /dev/null 2>/dev/null
- if test $? -eq 0; then
- if test "$build_os" = "cygwin"; then
- # nss requires the Windows version of ninja (but uses its Unix path)
- if test -n "$($a -t list | grep 'msvc')" ; then
- NINJA=`which $a`
- fi
- else
- NINJA=`which $a`
- fi
- fi
- if test -n "$NINJA"; then
- break
- fi
- fi
-done
-if test -n "$NINJA"; then
- AC_MSG_RESULT($NINJA)
-else
- AC_MSG_RESULT(not found)
-fi
-if test -z "$NINJA" -a "$nss_needs_ninja" = "yes" -a -n "$ENABLE_NSS" -a -z "$SYSTEM_NSS"; then
- AC_MSG_ERROR([Not found. NSS build requires Ninja (https://ninja-build.org/).])
-fi
-AC_SUBST(NINJA)
-
-dnl ===================================================================
dnl Check for TLS/SSL and cryptographic implementation to use
dnl ===================================================================
AC_MSG_CHECKING([which TLS/SSL and cryptographic implementation to use])