summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-04-17 15:40:50 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-04-17 17:25:03 +0200
commit92f6f9ec785f1009e2c94082a751696c74eaf236 (patch)
tree2b1dd2a91f16eab2ab2358864ad4618e8aa52c92 /configure.ac
parent4d1bd3cba9b4c971c05974a2805b018ec8ba18e2 (diff)
No need for HAVE_GCC_PRAGMA_OPERATOR
The _Pragma operator is a C99/C++11 feature, and we only need it for GCC and Clang anyway, to inject some #pragma GCC diagnostic ... directives. (MSVC would only support it with the upcoming VS 2019 Version 16.6, see <https://devblogs.microsoft.com/cppblog/ announcing-full-support-for-a-c-c-conformant-preprocessor-in-msvc/>.) Change-Id: I6de3611021a28ba13860f55e7ad005ad3fbbb5e2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92452 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 42945571edf9..309b298398c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6645,22 +6645,6 @@ return !(i != 0 && j != 0);
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
-dnl _Pragma support (may require C++11)
-if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
- AC_MSG_CHECKING([whether $CXX_BASE supports _Pragma operator])
- AC_LANG_PUSH([C++])
- save_CXXFLAGS=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11 -Werror"
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- _Pragma("GCC diagnostic ignored \"-Wformat\"")
- ])], [
- AC_DEFINE([HAVE_GCC_PRAGMA_OPERATOR],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
- AC_LANG_POP([C++])
- CXXFLAGS=$save_CXXFLAGS
-fi
-
HAVE_GCC_FNO_SIZED_DEALLOCATION=
if test "$GCC" = yes; then
AC_MSG_CHECKING([whether $CXX_BASE supports -fno-sized-deallocation])