summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2019-11-27 15:29:50 +0100
committerJan Holesovsky <kendy@collabora.com>2019-12-02 09:04:47 +0100
commit94eb59078731b2e4093d983bc618d051f4e31740 (patch)
tree7daae1b7585b13e3ebd77b8ea8aacdfa6c5cb685 /configure.ac
parentf3af7708e3535d3171832aa2308d1e7f6193def4 (diff)
android: Fix location of the built freetype library.
Otherwise it is not found when the the fontconfig's ./configure is running, which leads to linking failure during the fontconfig's ./configure time, which leads to an undefined HAVE_FT_GET_NEXT_CHAR which leads to not using the actual FT_Get_Next_Char, but instead some dummy code that leads to an infinite loop on the app startup; huh. Change-Id: I40b7a403fbe75582bb98f15f1afe7a4050fd13aa Reviewed-on: https://gerrit.libreoffice.org/83922 Reviewed-by: Jan Holesovsky <kendy@collabora.com> Tested-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1d848685cfef..7f86fa5b321a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8108,7 +8108,11 @@ if test "$test_freetype" = "yes"; then
SYSTEM_FREETYPE=TRUE
else
FREETYPE_CFLAGS="${ISYSTEM}${WORKDIR}/UnpackedTarball/freetype/include"
- FREETYPE_LIBS="-L${WORKDIR}/UnpackedTarball/freetype/instdir/lib -lfreetype"
+ if test "x$ac_config_site_64bit_host" = xYES; then
+ FREETYPE_LIBS="-L${WORKDIR}/UnpackedTarball/freetype/instdir/lib64 -lfreetype"
+ else
+ FREETYPE_LIBS="-L${WORKDIR}/UnpackedTarball/freetype/instdir/lib -lfreetype"
+ fi
fi
AC_SUBST(FREETYPE_CFLAGS)
AC_SUBST(FREETYPE_LIBS)