summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2021-04-08 17:01:15 +0200
committerLuboš Luňák <l.lunak@collabora.com>2021-04-09 10:09:07 +0200
commit422c939f44eec82aca1060d22ea9a95a44d6b17d (patch)
tree9ca0cfb823bb20a373e2af80afef5e2ef5490f80 /configure.ac
parent200626e41f004b6b8588f89fa3707c71ae2b375c (diff)
make clang plugin check code in headers only once if in PCH
When using Clang PCHs, we know for certain that the content of a PCH will be used once by the PCH's dedicated source file. So it is not necessary to let clang plugin check locations coming from a PCH every time, but just once when compiling that dedicated source. For starmath's parse.cxx this reduces compilation time 0.94s->0.4s (0.1s when not using plugins at all), for sc's document.cxx it is 5.9s->5.0s (4.0s without plugins). For reference, without PCHs the numbers are (with/without plugins) 2.1s/1.9s for parse.cxx and 11.2s/10.3s for document.cxx. Change-Id: Ie39787e65d7951187941dcff4899d053da63cbdd Reviewed-on: https://gerrit.libreoffice.org/c/core/+/113817 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a03dd38290f..cfc63ed6b6f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5779,6 +5779,7 @@ if test -n "$ENABLE_PCH"; then
CFLAGS=$save_CFLAGS
if test -n "$BUILDING_PCH_WITH_OBJ"; then
AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_BUILDING_PCH_WITH_OBJ)
else
AC_MSG_RESULT(no)
fi