summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2021-07-21 21:39:23 +0200
committerLuboš Luňák <l.lunak@collabora.com>2021-07-26 13:32:37 +0200
commit5d051f443bcd4b79041ef379bf032b76616f9ce2 (patch)
tree2b3ff9f6b5ea064ce085222e8c94b13751347735 /configure.ac
parent2fb06e18ae6fcf4813d98aa3fda0bcd1c9b9a7d0 (diff)
build Skia also on Mac
This only builds the library, without using it. Change-Id: I54e940bcaa61852b831dbe7ae5660a5daf5fe609 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/119356 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2ca6f8d4edd..675a6a1e8395 100644
--- a/configure.ac
+++ b/configure.ac
@@ -928,6 +928,7 @@ cygwin*|wsl*)
darwin*|macos*) # macOS
using_freetype_fontconfig=no
using_x11=no
+ build_skia=yes
if test -n "$LODE_HOME" ; then
mac_sanitize_path
AC_MSG_NOTICE([sanitized the PATH to $PATH])
@@ -11968,6 +11969,12 @@ if test "$enable_skia" != "no" -a "$build_skia" = "yes" -a -z "$DISABLE_GUI"; th
ENABLE_SKIA=TRUE
AC_DEFINE(HAVE_FEATURE_SKIA)
BUILD_TYPE="$BUILD_TYPE SKIA"
+
+ if test -n "$MAC_OS_X_VERSION_MIN_REQUIRED" -a "$MAC_OS_X_VERSION_MIN_REQUIRED" -lt "101200"; then
+ SKIA_DISABLE_VMA_USE_STL_SHARED_MUTEX=1
+ AC_SUBST(SKIA_DISABLE_VMA_USE_STL_SHARED_MUTEX)
+ fi
+
else
AC_MSG_RESULT([no])
fi