summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2015-01-22 12:42:16 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-01-26 10:27:44 +0100
commit718e46c16d8e1749f78f40eeeb54b4f14b375918 (patch)
tree230cbffa8e0d0ce5d9a73d59b9953d22c0c04588 /configure.ac
parentdbde7f6ab8106649cf7e153bda07c50753f2dad3 (diff)
configure: fix --with-android-package-name wrt ndk-gdb
Default to the package name that makes ndk-gdb happy in case --enable-dbgutil is used (can be extended later to --enable-symbols / --enable-debug as well, if necessary). Change-Id: If9dc09f48c895a4a138c3911f129e84f001d5f43
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 484de1336c38..f20dac0b9a7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12311,7 +12311,12 @@ if echo "$host_os" | grep -q linux-android ; then
ANDROID_PACKAGE_NAME=
AC_MSG_CHECKING([for Android package name])
if test -z "$with_android_package_name" -o "$with_android_package_name" = "no"; then
- ANDROID_PACKAGE_NAME="org.example"
+ if test -n "$ENABLE_DBGUTIL"; then
+ # Default to the package name that makes ndk-gdb happy.
+ ANDROID_PACKAGE_NAME="org.libreoffice"
+ else
+ ANDROID_PACKAGE_NAME="org.example.libreoffice"
+ fi
AC_MSG_RESULT([not set, using $ANDROID_PACKAGE_NAME])
else