summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-01-23 13:30:27 +0200
committerTor Lillqvist <tml@collabora.com>2015-01-23 13:30:27 +0200
commita19b47b5d3e8f20adad614622dd93543a2dc667a (patch)
tree33d0b7231f11929752b4af9b78ae5559ab854640 /configure.ac
parent6acfc822566ca3c7d9fdd4af37ad5104a00d5d35 (diff)
Make the --with-android-ndk-toolchain-version switch optional
Default to 4.9. Change-Id: I534b579fece83cfac79cfcd92f40bde5d2f801f5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b147aa8b501e..5c67205a7064 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,10 +285,7 @@ AC_ARG_WITH(android-ndk,
AC_ARG_WITH(android-ndk-toolchain-version,
AS_HELP_STRING([--with-android-ndk-toolchain-version],
[Specify which toolchain version to use, of those present in the
- Android NDK you are using. Mandatory if the NDK used has several
- toolchain versions for the host architecture you are building for.
- Possible values are 4.6, 4.8, clang3.3 and clang3.4. Only 4.8 has been
- tested for real...]), ,)
+ Android NDK you are using. The default is 4.9 currently.]), ,)
AC_ARG_WITH(android-sdk,
AS_HELP_STRING([--with-android-sdk],
@@ -331,6 +328,11 @@ if test -n "$with_android_ndk"; then
android_platform_prefix=$android_cpu
fi
+ if test -z "$with_android_ndk_toolchain_version"; then
+ # Default to gcc 4.9
+ with_android_ndk_toolchain_version=4.9
+ fi
+
case "$with_android_ndk_toolchain_version" in
4.6|4.7|4.8|4.9)
ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-$with_android_ndk_toolchain_version