summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-03-03 23:33:48 +0100
committerMichael Stahl <mstahl@redhat.com>2015-03-03 23:48:26 +0100
commitc503d3780fd095cc94103bf0f89b662c446b3b2b (patch)
treeee84f9d8bcf81446dd56b792e293588c8b3ec86f /configure.ac
parentd35d893c3d256223efc59e5bbdacce08352fd901 (diff)
configure: properly check for Windows SDK 8.1A
Due to the wildcard checking for it will actually attempt to check for the SDK 8.0, which fails with Visual Studio 2013 because its SDK 8.0 apparently lacks a midl.exe, so configure fails. Change-Id: Ib0e61a3a999d6a2ebe16645225fc9838dab3bdb1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e7e7f4717b35..2b664ac4f270 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5096,7 +5096,7 @@ find_winsdk_version()
return
fi
;;
- 8.1)
+ 8.1|8.1A)
reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows Kits/Installed Roots/KitsRoot81"
if test -n "$regvalue"; then
winsdktest=$regvalue
@@ -5104,7 +5104,7 @@ find_winsdk_version()
return
fi
;;
- 8.*)
+ 8.0|8.0A)
reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows Kits/Installed Roots/KitsRoot"
if test -n "$regvalue"; then
winsdktest=$regvalue