summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-12-14 07:09:58 +0100
committerMichael Stahl <mstahl@redhat.com>2016-12-14 15:16:02 +0000
commitd9aec10456ddc1787a7afe91502b91da616e2b0d (patch)
treebb2b72febae37c4f65e2b6d3edbce0b37101698c /configure.ac
parent4e9dd6e1b79983db087790a50c811b8b14b65f8f (diff)
check for EGL if we built with GTK3 support
Change-Id: Ib944b8109c734f01ca67783c286c8e10e07a1d25 Reviewed-on: https://gerrit.libreoffice.org/31993 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38a98dda14c3..251d048e5477 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10106,6 +10106,7 @@ if test "x$enable_gtk3" = "xyes"; then
GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTK3_LIBS}"
GTK3_LIBS="${filteredlibs}"
+ AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)