summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej Hunt <andrzej@ahunt.org>2021-07-04 14:54:43 +0200
committerCaolán McNamara <caolanm@redhat.com>2021-07-04 20:35:03 +0200
commite1d3c8438ade045aab4452dd59000d27f810ca91 (patch)
tree42cee8a3212ad521a0fdf778ff450afbe8e29c22 /configure.ac
parentc551e34018d7392f44ff8d7216dda4a480c6eea7 (diff)
Fix LIB_FUZZING_ENGINE not-empty check
Switch to '-z $LIB_FUZZING_ENGINE' to check if LIB_FUZZING_ENGINE is set. The previous version evaluates to false when LIB_FUZZING_ENGINE is not set, meaning you would not be warned at configure time when using -enable_fuzzers without setting LIB_FUZZING_ENGINE. Original broken version landed in: 44b36a0602b04342566362bce3f6bed7d2b096e4 ( https://gerrit.libreoffice.org/c/core/+/111691 ) Change-Id: Ic2174777ebf724e471cd605ba54b245e4e804705 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/118372 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7a9eaf39b24b..b2ca6f8d4edd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10637,7 +10637,7 @@ AC_MSG_CHECKING([whether to enable fuzzers])
if test "$enable_fuzzers" != yes; then
AC_MSG_RESULT([no])
else
- if test $LIB_FUZZING_ENGINE == ""; then
+ if test -z $LIB_FUZZING_ENGINE; then
AC_MSG_ERROR(['LIB_FUZZING_ENGINE' must be set when using --enable-fuzzers. Examples include '-fsanitize=fuzzer'.])
fi
AC_MSG_RESULT([yes])