summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrés Maldonado <amaldonado@linagora.com>2019-03-28 11:51:08 +0100
committerMichael Stahl <Michael.Stahl@cib.de>2019-04-01 18:09:31 +0200
commit0547ca68c89b8726bc1b37828cd352fec80cbf26 (patch)
tree0e565d3c03ba16ad76ae34e5a181376eeaa6ff0d /configure.ac
parent0ef7bc8a1d2f00715d6849f1bbceb26e32382d41 (diff)
Use "Visual C++ ATL (x86/x64) with Spectre Mitigations" if available
Change-Id: Iab63cf16f8c12c8148a8ac7eaea68007d4c27f23 Reviewed-on: https://gerrit.libreoffice.org/69891 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 49330125ef24..a20732568ce9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3532,7 +3532,8 @@ if test "$_os" = "WINNT"; then
CXX_X64_BINARY="$VC_PRODUCT_DIR/bin/x86_amd64/cl.exe"
LINK_X64_BINARY="$VC_PRODUCT_DIR/bin/x86_amd64/link.exe"
fi
- elif test -f "$VC_PRODUCT_DIR/Tools/MSVC/$vcbuildnumber/atlmfc/lib/x64/atls.lib"; then
+ elif test -f "$VC_PRODUCT_DIR/Tools/MSVC/$vcbuildnumber/atlmfc/lib/x64/atls.lib" || \
+ test -f "$VC_PRODUCT_DIR/Tools/MSVC/$vcbuildnumber/atlmfc/lib/spectre/x64/atls.lib"; then
# nobody uses 32-bit OS to build, just pick the 64-bit compiler
if "$VC_PRODUCT_DIR/Tools/MSVC/$vcbuildnumber/bin/HostX64/x64/cl.exe" -? </dev/null >/dev/null 2>&1; then
BUILD_X64=TRUE
@@ -12623,7 +12624,10 @@ AC_MSG_NOTICE([setting up the build environment variables...])
AC_SUBST(COMPATH)
if test "$build_os" = "cygwin"; then
- if test -d "$COMPATH/atlmfc/lib"; then
+ if test -d "$COMPATH/atlmfc/lib/spectre"; then
+ ATL_LIB="$COMPATH/atlmfc/lib/spectre"
+ ATL_INCLUDE="$COMPATH/atlmfc/include"
+ elif test -d "$COMPATH/atlmfc/lib"; then
ATL_LIB="$COMPATH/atlmfc/lib"
ATL_INCLUDE="$COMPATH/atlmfc/include"
else