summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-01-20 16:06:59 +0100
committerStephan Bergmann <sbergman@redhat.com>2021-01-21 07:58:18 +0100
commit067297cb7d81f442f8fed1bd40e52a109688320d (patch)
treef67a3012eb5f1ba0cbe3353b5691a88243473648 /configure.ac
parentaf34108d90bbbce90cf00c4b23961787599c7fa5 (diff)
Avoid Clang -Werror,-Wunused-command-line-argument
> [CXX] bridges/source/cpp_uno/gcc3_linux_aarch64/callvirtualfunction.cxx > clang-12: error: argument unused during compilation: '-fno-stack-clash-protection' [-Werror,-Wunused-command-line-argument] as seen e.g. on macOS 11.1 ARM64 when building against Clang 12 trunk. Clang supports -fstack-clash-protection on > $ clang --target=x86_64-unknown-linux-gnu -fstack-clash-protection -fsyntax-only -x c - </dev/null but not on e.g. > $ clang --target=aarch64-unknown-linux-gnu -fstack-clash-protection -fsyntax-only -x c - </dev/null > clang-12: warning: argument unused during compilation: '-fstack-clash-protection' [-Wunused-command-line-argument] or > $ clang --target=arm64-apple-macosx11.0.0 -fstack-clash-protection -fsyntax-only -x c - </dev/null > clang-12: warning: argument unused during compilation: '-fstack-clash-protection' [-Wunused-command-line-argument] Change-Id: I98625bb7ed37bf00e97634c1c8d1f87fe3263af9 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109719 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f60c1ae5a199..53c393bbc067 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6809,7 +6809,7 @@ HAVE_GCC_STACK_CLASH_PROTECTION=
if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_CHECKING([whether $CC_BASE supports -fstack-clash-protection])
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -fstack-clash-protection"
+ CFLAGS="$CFLAGS -Werror -fstack-clash-protection"
AC_LINK_IFELSE(
[AC_LANG_PROGRAM(, [[return 0;]])],
[AC_MSG_RESULT([yes]); HAVE_GCC_STACK_CLASH_PROTECTION=TRUE],