summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Nabet <serval2412@yahoo.fr>2020-12-25 12:43:41 +0100
committerJulien Nabet <serval2412@yahoo.fr>2020-12-25 14:18:24 +0100
commit747856aa3dbe9d3a438a3b01fa631124ee057ae8 (patch)
tree04a03eecf280b330f7badb0bca28af85efcc5aa0 /configure.ac
parentd0f4740843a052cd444efbd142ef2b66e233ddb9 (diff)
Remove vlc part since experimental since 5 years
However considering git history about vlc part (see https://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=vlc) it seems there's no real patch since 2013 + it's been explicitely indicated as experimental since 2015 See http://document-foundation-mail-archive.969070.n3.nabble.com/About-vcl-status-in-avmedia-keep-or-removed-unmaintained-code-since-7-years-tt4293282.html Of course if someone wants to keep on the work on it, it's always possible to revert the patch. Change-Id: Ia1602ea61b7ffa577148a80f974ebdcb71495fbb Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108283 Tested-by: Jenkins Reviewed-by: Julien Nabet <serval2412@yahoo.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index bffdbd69cae6..79d9a40c54ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1099,7 +1099,6 @@ haiku*)
test_freetype=yes
enable_odk=no
enable_gstreamer_1_0=no
- enable_vlc=no
enable_coinmp=no
enable_pdfium=no
enable_sdremote=no
@@ -1603,11 +1602,6 @@ libo_FUZZ_ARG_ENABLE(gstreamer-1-0,
[Disable building with the gstreamer 1.0 avmedia backend.]),
,test "${enable_gstreamer_1_0+set}" = set || enable_gstreamer_1_0=yes)
-libo_FUZZ_ARG_ENABLE(vlc,
- AS_HELP_STRING([--enable-vlc],
- [Enable building with the (experimental) VLC avmedia backend.]),
-,test "${enable_vlc+set}" = set || enable_vlc=no)
-
libo_FUZZ_ARG_ENABLE(neon,
AS_HELP_STRING([--disable-neon],
[Disable neon and the compilation of webdav binding.]),
@@ -11451,21 +11445,6 @@ AC_SUBST(GSTREAMER_1_0_CFLAGS)
AC_SUBST(GSTREAMER_1_0_LIBS)
AC_SUBST(ENABLE_GSTREAMER_1_0)
-dnl ===================================================================
-dnl Check whether to build the VLC avmedia backend
-dnl ===================================================================
-
-ENABLE_VLC=""
-
-AC_MSG_CHECKING([whether to enable the VLC avmedia backend])
-if test "$enable_avmedia" = yes -a $_os != iOS -a $_os != Android -a "$enable_vlc" = yes; then
- ENABLE_VLC="TRUE"
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_VLC)
-
ENABLE_OPENGL_TRANSITIONS=
ENABLE_OPENGL_CANVAS=
if test $_os = iOS -o $_os = Android -o "$ENABLE_FUZZERS" = "TRUE"; then