summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2012-11-25 12:46:10 +0100
committerJan Holesovsky <kendy@suse.cz>2012-11-25 12:46:50 +0100
commit7861bf081e2802a16f0be31edf7b3d1667f238dc (patch)
tree0314e7101bd9fa50c52b23dd4bcfbdc37c05f7fa /configure.ac
parent71103fd8d95e67e13652b13a7d58c6d70b6ad593 (diff)
Update to be able to at least start the MinGW build again.
Change-Id: I51a3cf81bf6ba4f0d50cb3f2ac52c2d220955b56
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 13 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 605dd1aa2b6f..dd4c40d9987f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4158,6 +4158,7 @@ if test "$cross_compiling" = "yes"; then
./configure \
--disable-graphite \
--disable-build-mozilla \
+ --disable-pdfimport \
--disable-postgresql-sdbc \
--disable-zenity \
--with-parallelism="$with_parallelism" \
@@ -6938,9 +6939,11 @@ if test "$with_system_expat" = "yes"; then
else
AC_MSG_RESULT([internal])
SYSTEM_EXPAT=NO
- EXPAT_TARBALL="dd7dab7a5fea97d2a6a43f511449b7cd-expat-2.1.0.tar.gz"
BUILD_TYPE="$BUILD_TYPE EXPAT"
fi
+if test "$with_system_expat" != "yes" -o "$with_system_expat_for_build" != "yes"; then
+ EXPAT_TARBALL="dd7dab7a5fea97d2a6a43f511449b7cd-expat-2.1.0.tar.gz"
+fi
AC_SUBST(SYSTEM_EXPAT)
AC_SUBST(EXPAT_TARBALL)
AC_SUBST([MINGW_EXPAT_DLL])
@@ -7087,9 +7090,11 @@ if test "$with_system_cppunit" = "yes"; then
else
AC_MSG_RESULT([internal])
SYSTEM_CPPUNIT=NO
- CPPUNIT_TARBALL="fa9aa839145cdf860bf596532bb8af97-cppunit-1.13.1.tar.gz"
BUILD_TYPE="$BUILD_TYPE CPPUNIT"
fi
+if test "$with_system_cppunit" != "yes" -o "$with_system_cppunit_for_build" != "yes"; then
+ CPPUNIT_TARBALL="fa9aa839145cdf860bf596532bb8af97-cppunit-1.13.1.tar.gz"
+fi
AC_SUBST(SYSTEM_CPPUNIT)
AC_SUBST(CPPUNIT_CFLAGS)
AC_SUBST(CPPUNIT_LIBS)
@@ -7924,6 +7929,8 @@ else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE BOOST"
SYSTEM_BOOST=NO
+fi
+if test "$with_system_boost" != "yes" -o "$with_system_boost_for_build" != "yes"; then
BOOST_TARBALL=f02578f5218f217a9f20e9c30e119c6a-boost_1_44_0.tar.bz2
fi
AC_SUBST([MINGW_BOOST_DATE_TIME_DLL])
@@ -8476,6 +8483,10 @@ You can use --with-system-icu-for-build=force to use it anyway.])
else
AC_MSG_RESULT([internal])
SYSTEM_ICU="NO"
+
+ BUILD_TYPE="$BUILD_TYPE ICU"
+fi
+if test "$with_system_icu" != "yes" -o "$with_system_icu_for_build" != "yes"; then
ICU_TARBALL="7c53f83e0327343f4060c0eb83842daf-icu4c-49_1_1-src.tgz"
# Save space when using a bundled ICU by leaving out unneeded parts of the ICU data. Generated by
@@ -8487,10 +8498,7 @@ else
# appropriately. Let's not bother trying to list what stuff has been removed in the file name.
# Describe it in the comment above instead.
ICU_DATA_SUBSET_ZIP=fc188d2ed5c2cbcf7a021b34b9f88478-icudt49l-subset.zip
-
- BUILD_TYPE="$BUILD_TYPE ICU"
fi
-
AC_SUBST(SYSTEM_ICU)
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
@@ -12490,14 +12498,6 @@ fi
AC_SUBST(LO_PATH)
-BUILD_TARBALLS=
-# Ugly hack to get what we need for build platform into ooo.lst
-if test "$CROSS_COMPILING" = "YES" ; then
- # ICU_DATA_SUBSET_ZIP
- BUILD_TARBALLS="$BUILD_TARBALLS fc188d2ed5c2cbcf7a021b34b9f88478-icudt49l-subset.zip"
-fi
-AC_SUBST(BUILD_TARBALLS)
-
# make sure config.guess is +x; we execute config.guess, so it has to be so
chmod +x ./config.guess