summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2020-05-07 09:42:22 +0200
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2020-06-05 01:10:15 +0200
commit8b6c0b73afbf201ffef6541625b902939dd116f6 (patch)
treec04311f678eda22da781ff60d7cb8df8f50363d0 /configure.ac
parent367c6c78fe9336a363a7a0e582a2e0c0d7c84a4f (diff)
tdf#131572 Add java 9 module info for libreoffice.jar
Add a java module named "org.libreoffice.uno" for this jar. This needs to be compiled with Java 9. But since we want to keep b/c with Java 8, the rest of the jar has to be compiled with Java 8. This bumps the *build* requirement to Java 9 while keeping the *runtime* requirement at Java 8. The gbuild JavaClassSet class is changed to invoke javac twice, where the 2nd invocation compiles with --release 9 and a --patch-modules argument so that it finds the results of the first invocation and also the javamaker generated files in CustomTargets. Change-Id: I888f5dbe097cc37136e68db5919939877c981862 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/91105 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> (cherry picked from commit 941b567a41569260fef14a7337511e8f42337323) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/95049 Reviewed-by: Michael Stahl <michael.stahl@cib.de> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 8 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 10da45dafaa9..de98eeaca272 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1970,7 +1970,7 @@ AC_ARG_WITH(linker-hash-style,
AC_ARG_WITH(jdk-home,
AS_HELP_STRING([--with-jdk-home=<absolute path to JDK home>],
- [If you have installed JDK 8 or later on your system please supply the
+ [If you have installed JDK 9 or later on your system please supply the
path here. Note that this is not the location of the java command but the
location of the entire distribution.]),
,)
@@ -7278,20 +7278,12 @@ if test "$ENABLE_JAVA" != ""; then
reg_get_value "$bitness" "HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/JDK/$ver/JavaHome"
_jdk_home=$regvalue
fi
- if test -z "$with_jdk_home"; then
- for ver in 1.8; do
- reg_get_value "$bitness" "HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit/$ver/JavaHome"
- if test -n "$regvalue"; then
- _jdk_home=$regvalue
- break
- fi
- done
- fi
+
if test -f "$_jdk_home/lib/jvm.lib" -a -f "$_jdk_home/bin/java.exe"; then
with_jdk_home="$_jdk_home"
howfound="found automatically"
else
- AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option pointing to a $bitness-bit JDK])
+ AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option pointing to a $bitness-bit JDK >= 9])
fi
else
test "$build_os" = "cygwin" && with_jdk_home=`win_short_path_for_make "$with_jdk_home"`
@@ -7373,24 +7365,7 @@ if test "$ENABLE_JAVA" != ""; then
elif test `$JAVAINTERPRETER -version 2>&1 | $AWK '{ print }' | $GREP -c "BEA"` -gt 0; then
AC_MSG_ERROR([No valid check available. Please check the block for your desired java in configure.ac])
elif test `$JAVAINTERPRETER -version 2>&1 | $AWK '{ print }' | $GREP -c "IBM"` -gt 0; then
- JDK=ibm
-
- dnl IBM JDK specific tests
- _jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED s/[[-A-Za-z]]*//`
- _jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
-
- if test "$_jdk_ver" -lt 10800; then
- AC_MSG_ERROR([IBM JDK is too old, you need at least 8])
- fi
-
- AC_MSG_RESULT([found (IBM JDK $_jdk)])
-
- if test "$with_jdk_home" = ""; then
- AC_MSG_ERROR([In order to successfully build LibreOffice using the IBM JDK,
-you must use the "--with-jdk-home" configure option explicitly])
- fi
-
- JAVA_HOME=$with_jdk_home
+ AC_MSG_ERROR([No valid check available. Please check the block for your desired java in configure.ac])
else
JDK=sun
@@ -7398,10 +7373,10 @@ you must use the "--with-jdk-home" configure option explicitly])
_jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED '/^$/d' | $SED s/[[-A-Za-z]]*//`
_jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
- if test "$_jdk_ver" -lt 10800; then
- AC_MSG_ERROR([JDK is too old, you need at least 8])
+ if test "$_jdk_ver" -lt 10900; then
+ AC_MSG_ERROR([JDK is too old, you need at least 9])
fi
- if test "$_jdk_ver" -gt 10800; then
+ if test "$_jdk_ver" -gt 10900; then
JAVA_CLASSPATH_NOT_SET=TRUE
fi
@@ -7417,7 +7392,7 @@ you must use the "--with-jdk-home" configure option explicitly])
JAVAFLAGS=-J-Xmx128M
fi
else
- AC_MSG_ERROR([Java not found. You need at least JDK 8])
+ AC_MSG_ERROR([Java not found. You need at least JDK 9])
fi
else
dnl Java disabled