summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPranav Kant <pranavk@gnome.org>2015-08-15 18:48:53 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2015-09-14 07:58:16 +0000
commit8f2aace934eb2a91a273b6104de6383108b5c82a (patch)
treedaa8b76b0d9327c9d6397a125aa192533ea9a2ab /configure.ac
parentb018b02ef550a1f9fc7ce61a2a81707c0f5eda16 (diff)
create_tree.sh: Generate g-i files
Change-Id: I1749b5b02018cfe6f85a13aed8de4b31a09788e3 Reviewed-on: https://gerrit.libreoffice.org/18494 Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk> Tested-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65a313a8be86..dda7e15a2c9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,6 +201,11 @@ SRC_ROOT=`pwd`
cd $BUILDDIR
x_Cygwin=[\#]
+dnl ======================================
+dnl Required GObject introspection version
+dnl ======================================
+INTROSPECTION_REQUIRED_VERSION=1.32.0
+
dnl ===================================================================
dnl Search all the common names for GNU Make
dnl ===================================================================
@@ -9957,6 +9962,7 @@ if test "x$enable_gtk3" = "xyes"; then
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.8 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
+ GOBJECT_INTROSPECTION_CHECK(INTROSPECTION_REQUIRED_VERSION)
else
AC_MSG_ERROR([gtk3 or dependent libraries of the correct versions, not found])
fi