summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-10-11 23:16:59 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-10-12 08:09:51 +0200
commit9db11a8ab648f4d04e59e6bb94cd640f64835447 (patch)
tree2453c8270671e61e034ac59077d31a841552e209 /configure.ac
parent82a763d78c168192263765b38f23c93346096243 (diff)
-fstack-protector-strong is long since available
...on our baselines, since <https://gcc.gnu.org/git/ ?p=gcc.git;a=commitdiff;h=b156ec373ccf27f4fcce7972de5e043d35acea43> (GCC 4.9?) and <https://github.com/llvm/llvm-project/commit/ e0fc1a80cba8b91e3943f3287e7dcf68c6bb9b7f> "[stackprotector] Add command line option -fstack-protector-strong" (Clang 3.5?) Change-Id: I48237b2304a1ee273cc66f0bb458e890a5a2f21a Reviewed-on: https://gerrit.libreoffice.org/80700 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 0c8388fbc9a5..809ed94733a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6167,17 +6167,6 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING([whether $CC_BASE supports -fstack-protector-strong])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -O0 -Werror -fstack-protector-strong"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ char a[8]; a[7] = 0; ]])],[ HAVE_GCC_STACK_PROTECTOR_STRONG=TRUE ],[])
- CFLAGS=$save_CFLAGS
- if test "$HAVE_GCC_STACK_PROTECTOR_STRONG" = "TRUE"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-
AC_MSG_CHECKING([whether $CC_BASE supports atomic functions])
AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[
int v = 0;
@@ -6349,7 +6338,6 @@ AC_LANG_POP([C++])
fi
AC_SUBST(HAVE_GCC_AVX)
-AC_SUBST(HAVE_GCC_STACK_PROTECTOR_STRONG)
AC_SUBST(HAVE_GCC_BUILTIN_ATOMIC)
AC_SUBST(HAVE_GCC_BUILTIN_FFS)