summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-09-28 23:02:17 +0200
committerCaolán McNamara <caolanm@redhat.com>2018-10-16 12:30:44 +0200
commitd5d09bb733842252b3e2d6e7480b211e67136a75 (patch)
tree057a2e8177b4267f1472da41c08f6ea2921a1892 /configure.ac
parentdbba4c85e13ecd226f17550ca458738b9be24872 (diff)
tdf#72987 split firebird test into a regression test and a "new" test
former with endianness and latter with the new fbk format. Add new endianness-independent firebird test odbs This squashes tdf#72987 run firebird test for little endian only for now since those old(er) files still use the endianness-depending format. And remove x64 from the filename... Change-Id: I24e56cd8561c2ec6a1f77a66907c14cdea8248b6 Reviewed-on: https://gerrit.libreoffice.org/60916 Tested-by: Jenkins Reviewed-by: Rene Engelhard <rene@debian.org> and tdf#72987 split firebird test into a regression test and a "new" testHEADmaster former with endianness and latter with the new fbk format. Add new endianness-independent firebird test odbs Change-Id: I29be2e6916fcca74744211dba04463376fb6b8d5 Reviewed-on: https://gerrit.libreoffice.org/60917 Reviewed-by: Rene Engelhard <rene@debian.org> Tested-by: Rene Engelhard <rene@debian.org> Change-Id: I29be2e6916fcca74744211dba04463376fb6b8d5 Reviewed-on: https://gerrit.libreoffice.org/61285 Tested-by: Rene Engelhard <rene@debian.org> Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4176ef077b0a..38a39a35ebbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,6 +812,13 @@ haiku*)
;;
esac
+if test "$_os" != "WINNT"; then
+AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
+else
+ENDIANNESS=little
+fi
+AC_SUBST(ENDIANNESS)
+
if test "$_os" = "Android" ; then
# Verify that the NDK and SDK options are proper
if test -z "$with_android_ndk"; then