summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2016-11-06 21:03:40 +0100
committerAndras Timar <andras.timar@collabora.com>2017-02-28 10:54:22 +0100
commitd7cecbb355b2720cee28fde2e8610ffb257587fe (patch)
tree5c98beadef89f92ca07ecf4972f7a8e0db402c8a /configure.ac
parent915704b3f388dd7fd157c8715d3afc336a3ec54f (diff)
Bundle Google Noto fonts
(cherry picked from commit 1b6ec3bddf80775fe939875c188c61cd4241441e) Change-Id: Ic39ef335a5829d7472090d253af7d6c74393c05a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5149b922997..b5d4ae297404 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1589,6 +1589,11 @@ AC_ARG_WITH(fonts,
known to be available on the system then you should use this option.]),
,)
+AC_ARG_ENABLE(noto-font,
+ AS_HELP_STRING([--enable-noto-font],
+ [Add Google Noto font.]),
+,)
+
AC_ARG_WITH(epm,
AS_HELP_STRING([--with-epm],
[Decides which epm to use. Default is to use the one from the system if
@@ -11538,6 +11543,21 @@ fi
AC_SUBST(WITH_FONTS)
AC_DEFINE_UNQUOTED([TEST_FONTS_MISSING], $TEST_FONTS_MISSING)
+dnl Test whether to include Google Noto fonts
+dnl ===================================================================
+AC_MSG_CHECKING([whether to include Google Noto fonts])
+if test "$enable_noto_font" = "" -o "$enable_noto_font" = "no" -o "$with_fonts" = "no"; then
+ AC_MSG_RESULT([no])
+ WITH_NOTO_FONT=
+else
+ AC_MSG_RESULT([yes])
+ WITH_NOTO_FONT=TRUE
+ BUILD_TYPE="$BUILD_TYPE NOTO_FONT"
+ SCPDEFS="$SCPDEFS -DWITH_NOTO_FONT"
+fi
+AC_SUBST(WITH_NOTO_FONT)
+
+dnl ===================================================================
dnl ===================================================================
dnl Test whether to enable online update service