summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2018-04-03 13:16:53 +0200
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2018-04-04 00:01:56 +0200
commite2e3118465411448a3b1f5e56c3456384c009f99 (patch)
tree7e068bfa4104e3da39ba98af9e4c0344e6bb49c6 /configure.ac
parent5f3cacc4d9fa5cce94ae8e024cd7eb236bc52472 (diff)
configure: check for EGL header if EGL is required
Change-Id: Id7501b9adcd817ce84bfde3a928fe8b4c7e7e01f Reviewed-on: https://gerrit.libreoffice.org/52330 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2d5c8c5e320..744b4ee4b2ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9895,6 +9895,8 @@ if test "x$enable_gtk3" = "xyes"; then
dnl We require egl only for the gtk3 plugin. Otherwise we use glx.
if test "$with_system_epoxy" != "yes"; then
AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+ AC_CHECK_HEADER(EGL/eglplatform.h, [],
+ [AC_MSG_ERROR(EGL headers not found. install mesa-libEGL-devel)], [])
fi
fi
AC_SUBST(GTK3_LIBS)