summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-01-31 23:20:28 +0200
committerTor Lillqvist <tml@iki.fi>2013-01-31 23:23:37 +0200
commitf33c8056a856b20436206682ab72a34b08c15c88 (patch)
treeef1d992aa7c6780aa1354fbe8667651adf281c8c /configure.ac
parentc84e417a0f71778a5d6e0fa1ad4b10844ebd7787 (diff)
Enforce DISABLE_LINKOO on OS X
solenv/bin/linkoo doesn't do anything on OS X anyway, and even if it would do and it would work, it would interfere with signing the app bundle. Change-Id: If7a6cecea57cddf8a637a60872d0372eb5093f41
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2f7d5c4bdef..2c2d2727eb74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4328,6 +4328,10 @@ AC_SUBST(ASSERT_ALWAYS_ABORT)
dnl Determine whether to use linkoo for the smoketest installation
dnl ===================================================================
AC_MSG_CHECKING([whether to use linkoo for the smoketest installation])
+if test $_os = Darwin; then
+ enable_linkoo=no
+fi
+
if test "$enable_linkoo" = "no"; then
DISABLE_LINKOO="TRUE"
AC_MSG_RESULT([no])