summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2016-08-04 22:48:22 +0300
committerTor Lillqvist <tml@collabora.com>2016-08-04 22:48:22 +0300
commit4c94b91718a65b34038b917dd29f738be3f4f6cb (patch)
tree5e0345333394ad4c2c92129d19a902cbbf7497dd /configure.ac
parent124eec677920b4109f5a8b961aa54925548a9f7d (diff)
Accept also macOS SDK 10.12
Change-Id: I2e654de8af40486ef63146ad42a3f2988f9c3579
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e378892962fa..50fec94c2fa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2842,7 +2842,7 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11; do
+ for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2873,8 +2873,11 @@ if test $_os = Darwin; then
10.11)
MACOSX_SDK_VERSION=101100
;;
+ 10.12)
+ MACOSX_SDK_VERSION=101200
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--12])
;;
esac
@@ -2906,8 +2909,11 @@ if test $_os = Darwin; then
10.11)
MAC_OS_X_VERSION_MIN_REQUIRED="101100"
;;
+ 10.12)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101200"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--12])
;;
esac
@@ -2943,8 +2949,11 @@ if test $_os = Darwin; then
10.11)
MAC_OS_X_VERSION_MAX_ALLOWED="101100"
;;
+ 10.12)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101200"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--11])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--12])
;;
esac