summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-07-08 18:29:01 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-07-11 08:57:55 +0000
commit99db9f2295eb9a8b3288df9798a292b8d6e1b854 (patch)
treea38dd7e7d297275a856fe37db2eb663000cf5bff /configure.ac
parent436ee0989d1bc321886fac5a3507fc1d16650abd (diff)
Make --enable-symbols orthogonal to --enable-debug/-dbgutil
Change-Id: I523bc1d848e40489370eefe00046e0a257ed2505 Reviewed-on: https://gerrit.libreoffice.org/27058 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 12 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 11bb4680446c..a91de785034a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1150,9 +1150,9 @@ AC_ARG_ENABLE(selective-debuginfo,
AC_ARG_ENABLE(symbols,
AS_HELP_STRING([--enable-symbols],
- [Include debugging symbols in output while preserve optimization.
- This enables -g compiler flag for GCC or equivalent,
- without changing anything else compared to productive code.]))
+ [Generate debug information.
+ By default, enabled for --enable-debug and --enable-dbgutil, disabled
+ otherwise.]))
AC_ARG_ENABLE(runtime-optimizations,
AS_HELP_STRING([--disable-runtime-optimizations],
@@ -4034,14 +4034,16 @@ AC_SUBST(ENABLE_DEBUGINFO_FOR)
dnl Check for enable symbols option
dnl ===================================================================
-AC_MSG_CHECKING([whether to include symbols while preserve optimization])
-if test -n "$enable_symbols" -a "$enable_symbols" != "no"; then
- ENABLE_SYMBOLS="TRUE"
- if test -n "$ENABLE_DBGUTIL"; then
- AC_MSG_ERROR([--enable-dbgutil cannot be used with --enable-symbols])
- elif test -n "$ENABLE_DEBUG"; then
- AC_MSG_ERROR([--enable-debug cannot be used with --enable-symbols])
+AC_MSG_CHECKING([whether to generate debug information])
+if test -z "$enable_symbols"; then
+ if test -n "$ENABLE_DEBUG$ENABLE_DBGUTIL"; then
+ enable_symbols=yes
+ else
+ enable_symbols=no
fi
+fi
+if test "$enable_symbols" != no; then
+ ENABLE_SYMBOLS=TRUE
AC_MSG_RESULT([yes])
else
ENABLE_SYMBOLS=