summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2016-07-22 14:11:18 +0200
committerTor Lillqvist <tml@collabora.com>2016-07-22 15:22:31 +0300
commita911b96bb10b41a7f97ad40c423d84388d6b7d96 (patch)
treefe8e41c0ea3d95a805fdaafb46ecf9fad8500834 /configure.ac
parent5e46e382694587e88ecdebc7fa57e90fbaca7a76 (diff)
configure: remove mysterious NO_JAVA_HOME value
This has been there since CVS import, but no reason is given why an empty JAVA_HOME value wouldn't work as well. This caused 086c13584dc672c4a07c6384ab7f08fa67ce0f95 to always invoke autogen.sh if one used --without-java. Change-Id: Ie72537ddd0247700fdcdb4126387935754c1bed5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cd7c9c48acb5..8d0e785ae398 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7017,7 +7017,8 @@ you must use the "--with-jdk-home" configure option explicitly])
fi
else
dnl Java disabled
- JAVA_HOME=NO_JAVA_HOME ; export JAVA_HOME
+ JAVA_HOME=
+ export JAVA_HOME
fi
AC_SUBST([HAVE_JAVA6])
AC_SUBST([HAVE_JAVA9])
@@ -12633,7 +12634,7 @@ fi
ILIB1=
if test "$build_os" = "cygwin"; then
ILIB="."
- if test -n "$JAVA_HOME" -a "$JAVA_HOME" != "NO_JAVA_HOME"; then
+ if test -n "$JAVA_HOME"; then
ILIB="$ILIB;$JAVA_HOME/lib"
fi
ILIB1=-link