summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2016-08-03 22:12:29 +0300
committerTor Lillqvist <tml@collabora.com>2016-08-03 22:36:36 +0300
commite13aead8a19c65144fc254f9e3a694584ab1777c (patch)
tree10d67af40a0ee8dd5784b975fb30dca58a40e09d /configure.ac
parent1520d30268e1eebabbdf18b9a31bc783ab51d03c (diff)
Reduce ENABLE_OPENGL / ENABLE_HEADLESS confusion
ENABLE_OPENGL means whether to enable the OpenGL slideshow transition code. It does not mean whether to enable use of OpenGL in general. So rename it to ENABLE_OPENGL_TRANSITIONS while at it. ENABLE_HEADLESS means whether to disable use of X11 and OpenGL on X11 (and Wayland) platforms, I think, meaning Linux and maybe Solaris and the BSDs. Maybe it should be renamed to DISABLE_X11_AND_OPENGL. Change-Id: Ibb30f51646b1bcc477fe691a3fa38c7a1e3944ae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index b9e7217e30af..1ec225043428 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10451,29 +10451,29 @@ else
fi
AC_SUBST(ENABLE_VLC)
-# this is for opengl transitions in impress slideshow
-ENABLE_OPENGL=
+ENABLE_OPENGL_TRANSITIONS=
+ENABLE_OPENGL_CANVAS=
if test $_os = iOS -o $_os = Android; then
: # disable
elif test "$_os" = "Darwin"; then
# We use frameworks on Mac OS X, no need for detail checks
- ENABLE_OPENGL=TRUE
+ ENABLE_OPENGL_TRANSITIONS=TRUE
AC_DEFINE(HAVE_FEATURE_OPENGL,1)
ENABLE_OPENGL_CANVAS=TRUE
elif test $_os = WINNT; then
- ENABLE_OPENGL=TRUE
+ ENABLE_OPENGL_TRANSITIONS=TRUE
AC_DEFINE(HAVE_FEATURE_OPENGL,1)
ENABLE_OPENGL_CANVAS=TRUE
else
if test "$USING_X11" = TRUE; then
AC_CHECK_LIB(GL, glBegin, [:], AC_MSG_ERROR([libGL required.]))
- ENABLE_OPENGL=TRUE
+ ENABLE_OPENGL_TRANSITIONS=TRUE
AC_DEFINE(HAVE_FEATURE_OPENGL,1)
ENABLE_OPENGL_CANVAS=TRUE
fi
fi
-AC_SUBST(ENABLE_OPENGL)
+AC_SUBST(ENABLE_OPENGL_TRANSITIONS)
AC_SUBST(ENABLE_OPENGL_CANVAS)
dnl =================================================
@@ -12838,7 +12838,7 @@ if test "$enable_mpl_subset" = "yes"; then
esac
done
- ENABLE_OPENGL=
+ ENABLE_OPENGL_TRANSITIONS=
if test "$enable_lpsolve" != "no" -o "x$ENABLE_LPSOLVE" = "xTRUE"; then
AC_MSG_ERROR([need to --disable-lpsolve - calc linear programming solver.])