summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2013-02-05 15:18:43 +0100
committerPetr Mladek <pmladek@suse.cz>2013-02-05 15:18:43 +0100
commit81deb92029055af4471629a0d95170ad8a7b1cb6 (patch)
tree0e15c4796378dbcfce89d59ac1e088ea7e3190a3 /configure.ac
parent56d41fef8f96888d5aaf39a9c4d0c7eca5b63d44 (diff)
use "icerun" wrapper only when available
It is not provided by the old icecram-0.9.2 on SLED11 Change-Id: If8dc9b028276ac05733eb59c1ec62e352f4a2796
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51b9244cdbe0..c4ed1dd2df92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12237,9 +12237,13 @@ dnl icerun is a wrapper that stops us spawning tens of processes
dnl locally - for tools that can't be executed on the compile cluster
dnl this avoids a dozen javac's ganging up on your laptop to kill it.
dnl ===================================================================
+AC_MSG_CHECKING([whether to use icerun wrapper])
ICECREAM_RUN=
-if test "$enable_icecream" = "yes"; then
- ICECREAM_RUN=icerun
+if test "$enable_icecream" = "yes" && which icerun >/dev/null 2>&1 ; then
+ ICECREAM_RUN=icerun
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
fi
AC_SUBST(ICECREAM_RUN)