summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKorrawit Pruegsanusak <detective.conan.1412@gmail.com>2016-03-19 18:55:27 +0700
committerMichael Stahl <mstahl@redhat.com>2016-03-22 13:55:18 +0000
commite5d83653e78965a876b2ac1119736c4726bd783d (patch)
treec9dc1ea0a3c6ada947297bbb1d54537091b717ff /configure.ac
parent449cededd7f20b52e6bc417cd9351bfe3230cb05 (diff)
Explicitly check for libGL before building
Change-Id: I5a84bc396925828a11d3c680d1a52e99321547a1 Reviewed-on: https://gerrit.libreoffice.org/23335 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62ee6bf487ab..6e455d57d492 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10438,6 +10438,7 @@ elif test $_os = WINNT; then
else
if test "$USING_X11" = TRUE; then
ENABLE_OPENGL=TRUE
+ AC_CHECK_LIB(GL, glBegin, [:], AC_MSG_ERROR([libGL required.]))
fi
ENABLE_OPENGL_CANVAS=TRUE
fi