summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2014-10-15 14:44:27 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2014-10-15 14:56:59 -0500
commit0aa5a03af925276f011cd9de0b30b3760f656c8b (patch)
tree6dd7501c0d5a1e3322ddd9e3dbad2b91fc531c68 /configure.ac
parenta1a33bc181f058bef98a9a47dde3e77a3d8fb086 (diff)
use LODE_HOME when present to locat ant, junit and gnumake
LODE_HOME is an environment variable that stem from the LibreOffice Development Environment... a small project aimed at simplying the setup of a build environement for Libreoffice, for dev, release, tinderboxing or jenkins slave (see git://gerrit.libreoffice.org/lode ) Among other things it defines some standard locations where where some specific tools that usually require manual install are to be installed (and lode's ./setup take care of doing just that) Teaching configure.ac about these location simplyfy even more the autogen.input setup when using a lode setup. Change-Id: I43d5c11b59110300f69dadfb7fd1c96e94f81652
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1a56cb819f90..453b3adf860b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,7 +189,9 @@ AC_MSG_CHECKING([for GNU Make])
# try to use our own make if it is available and GNUMAKE was not already defined
if test -z "$GNUMAKE"; then
- if test -x "/opt/lo/bin/make"; then
+ if test -n "$LODE_HOME" -a -e "$LODE_HOME/bin/make" ; then
+ GNUMAKE="$LODE_HOME/opt/bin/make"
+ elif test -x "/opt/lo/bin/make"; then
GNUMAKE="/opt/lo/bin/make"
fi
fi
@@ -4649,6 +4651,9 @@ AC_SUBST([SYSTEM_FONTCONFIG])
dnl whether to find & fetch external tarballs?
dnl ===================================================================
+if test -z "$TARFILE_LOCATION" -a -n "$LODE_HOME" ; then
+ TARFILE_LOCATION="$LODE_HOME/ext_tar"
+fi
if test -z "$TARFILE_LOCATION"; then
if test -d "$SRC_ROOT/src" ; then
mv "$SRC_ROOT/src" "$SRC_ROOT/external/tarballs"
@@ -11856,6 +11861,9 @@ dnl ===================================================================
if test "$ENABLE_JAVA" != ""; then
ANT_HOME=; export ANT_HOME
WITH_ANT_HOME=; export WITH_ANT_HOME
+ if test -z "$with_ant_home" -a -n "$LODE_HOME" -a -e "$LODE_HOME/opt/bin/ant" ; then
+ with_ant_home="$LODE_HOME/opt"
+ fi
if test -z "$with_ant_home"; then
AC_PATH_PROGS(ANT, [jakarta-ant ant ant.sh ant.bat ant.cmd])
else
@@ -11997,7 +12005,9 @@ OOO_JUNIT_JAR=
if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no"; then
AC_MSG_CHECKING([for JUnit 4])
if test "$with_junit" = "yes"; then
- if test -e /usr/share/java/junit4.jar; then
+ if test -n "$LODE_HOME" -a -e "$LODE_HOME/opt/share/java/junit.jar" ; then
+ OOO_JUNIT_JAR="$LODE_HOME/opt/share/java/junit.jar"
+ elif test -e /usr/share/java/junit4.jar; then
OOO_JUNIT_JAR=/usr/share/java/junit4.jar
else
if test -e /usr/share/lib/java/junit.jar; then