summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noel@peralex.com>2014-11-20 16:02:57 +0200
committerNoel Grandin <noelgrandin@gmail.com>2014-11-21 08:41:31 +0000
commit40e7eecb7efeeb9af59206d7a9c82ac55adf5279 (patch)
tree6bcc8a15f8963fb88c651f2f335cf1502c52e606 /configure.ac
parent8e206be4ed997df73ef135d20694fc512b4d3d1b (diff)
add sanity checking to --with-iwyu
add some error checking so developers like me don't pass an empty --with-iwyu option and get weird compile time error messages. Change-Id: I142a0404db1bce905ce4d791f286d7bfc913078c Reviewed-on: https://gerrit.libreoffice.org/12988 Reviewed-by: Noel Grandin <noelgrandin@gmail.com> Tested-by: Noel Grandin <noelgrandin@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fe56ff382ce8..7d58d676b7a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2079,7 +2079,7 @@ AC_ARG_WITH(gssapi,
AC_ARG_WITH(iwyu,
AS_HELP_STRING([--with-iwyu],
- [Provide IWYU binary path to check unneeded includes instead of building.
+ [Use given IWYU binary path to check unneeded includes instead of building.
Use only if you are hacking on it.]),
,)
@@ -12512,6 +12512,12 @@ AC_SUBST(PARALLELISM)
IWYU_PATH="$with_iwyu"
AC_SUBST(IWYU_PATH)
+if test ! -z "$IWYU_PATH"; then
+ if test ! -f "$IWYU_PATH"; then
+ AC_MSG_ERROR([cannot find include-what-you-use binary specified by --with-iwyu])
+ fi
+fi
+
#
# Set up ILIB for MSVC build
#