summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-12-01 09:02:13 +0100
committerDavid Tardon <dtardon@redhat.com>2013-12-01 09:08:46 +0100
commit64736759bc1fa2014dc60247974c94379ee91aa5 (patch)
tree2bd283f438f4d4959b02738a3988de206d23f41b /configure.ac
parent80373a6969fd8d3c19231041e465372cf03f53f2 (diff)
upload libeot-0.01
Change-Id: I877cab5e13ebb52911b2e238a0f4ebb87cda73e9 (cherry picked from commit 0f4be588622379388650d8fc451829d17d16a7bf)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index e510bc6195f3..244fe0566190 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7707,28 +7707,12 @@ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_eot" = "yes"; then
AC_DEFINE([ENABLE_EOT])
AC_MSG_RESULT([yes])
- AC_MSG_CHECKING([which libeot to use])
- if test "$with_system_libeot" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_LIBEOT=YES
- AC_CHECK_HEADER([libeot.h], [],
- [AC_MSG_ERROR([libeot.h not found. install libeot])], [])
- AC_CHECK_LIB([libeot], [eot2ttf_file], [:],
- [AC_MSG_RESULT([libeot library not found or functional.])], [])
- libo_MINGW_CHECK_DLL([libeot])
- else
- AC_MSG_RESULT([internal])
- SYSTEM_LIBEOT=NO
- BUILD_TYPE="$BUILD_TYPE LIBEOT"
- fi
+ libo_CHECK_SYSTEM_MODULE([libeot],[LIBEOT],[libeot >= 0.01])
else
ENABLE_EOT=
AC_MSG_RESULT([no])
fi
AC_SUBST([ENABLE_EOT])
-AC_SUBST([SYSTEM_LIBEOT])
-AC_SUBST([LIBEOT_CFLAGS])
-AC_SUBST([LIBEOT_LIBS])
dnl ===================================================================
dnl Check for system libe-book